Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 03-24-2015, 10:07 AM   #1
Junior Member
 
Join Date: Feb 2012
Posts: 5
Precept Issues

I am having trouble with my cab heater , in winter driving the blower goes off and on, I have to turn off the heater to engage the blower again.

Also while driving my Hyd Jack control panel will flash and beep , scares the heck out of me .

Video camera System will go to "signal lost " why would this happen ?

Wind noise quite loud around the windshield

Any feedback would be appreciated .
__________________

Jayco Junkie is offline   Reply With Quote
Old 03-24-2015, 11:55 AM   #2
Senior Member
 
JoeMazz's Avatar
 
Join Date: May 2014
Location: Orlando
Posts: 179
Here's what I have found with a few of the issues you are having:
My hydraulic jacks were all screwed up. The issue ended up being the control board, which was located inside one of the pass through compartments under the coach. It had been sprayed with so much insulation to fill the hole the lines were pulled through that the board malfunctioned and had to be replace by the dealer.
Cameras losing signal might be a loose connecter behind the radio. It is easily accessed by removing the brown wood looking shroud around that part of the dash (much easier than trying to pull the radio out alone). The wires are well marked and you should be able to identify the camera cables. Look for a loose connection.
I haven't used my heater (I'm in Florida) and the windshield noise I just assumed was part of driving a shoebox at 65MPH, so I'm not much help with that.
Hope that helps...
__________________

__________________
Joe Mazz
2015 Precept 35UP
2017 Jeep Cherokee Trailhawk

JoeMazz is offline   Reply With Quote
Old 03-24-2015, 11:58 AM   #3
Senior Member
 
JoeMazz's Avatar
 
Join Date: May 2014
Location: Orlando
Posts: 179
We have a lot of Precept owners in the Precept Owners Group. I'm sure they could be a great help with your issues. Give that a shot too...
https://www.jaycoowners.com/forums/gr...%27+group.html
__________________
Joe Mazz
2015 Precept 35UP
2017 Jeep Cherokee Trailhawk

JoeMazz is offline   Reply With Quote
Old 03-24-2015, 01:17 PM   #4
Senior Member
 
Bobs A Class's Avatar
 
Join Date: Oct 2012
Location: Plainfield, IL
Posts: 158
My cab heater also does not work. No problems with the levelers, or Camera. I have heard of others having windshield noise problems and had to have the dealer reseal the windshield. Just a few of the things the dealer needs to fix when I get home.

Bob
__________________
Me, Mrs., Maggie
and Ted the pup
2015 Precept 31 UL
2015 Equinox, Blue Ox Avanta LX
Bobs A Class is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.