Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-27-2015, 08:45 AM   #1
Senior Member
 
Join Date: Dec 2014
Location: North Central Texas
Posts: 382
SENECA backup camera power

In checking out how delivery of my 36FK was going I found the backup camera on with the ignition switch off. In reading the owners manual the camera should power up with the ignition switch. The dealer rep told me that the camera operated off house power and was controlled by the house 12V switch. That doesn't sound right to me.

How does your SENECA camera power on/off?
__________________

__________________
Walt

2015 Jayco Seneca 36 FK
2016 Jeep Wrangler Unlimited tow
2010 Tiffin RED 36 QSA - gone
2011 Monaco Monarch class A - gone
WaltW is offline   Reply With Quote
Old 06-29-2015, 01:42 PM   #2
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 1,339
On my '14 Seneca it too is powered off the coach batteries. I know this because if I don't turn on the coach power, no picture! Actually all 3 (sides too) won't function.

Originally my in-dash nav/stereo was also hooked to coach power, but I got tired (very quickly) of the radio losing all its settings every time I shut off the batteries. It was probably supposed to have a continuous battery feed, but it did not. Now it does due to my efforts.
__________________

Robbbyr is offline   Reply With Quote
Old 06-30-2015, 10:50 AM   #3
Senior Member
 
Join Date: Dec 2014
Location: North Central Texas
Posts: 382
Robbbyr, I want to go the other way…radio/GPS/cameras go on/off with the ignition switch. I am not at all concerned about presets as we listen to CDs except when driving. When camping I use the OTA TV for weather advisories etc.

Thanks for your response
__________________
Walt

2015 Jayco Seneca 36 FK
2016 Jeep Wrangler Unlimited tow
2010 Tiffin RED 36 QSA - gone
2011 Monaco Monarch class A - gone
WaltW is offline   Reply With Quote
Old 06-30-2015, 12:04 PM   #4
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 1,339
I made some other mods to my stereo, I added Sirius for the long drives and put an Alpine compact subwoofer under the passenger seat to "fill-in" the missing bass. It actually sounds great now! I needed it to work even when chassis off and not forget all its settings since it also is the audio source for my overhead bunk TV. At least it is until I figure out whether I want a sound bar or not for the it!
Robbbyr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.