Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 03-01-2015, 05:44 PM   #1
Member
 
Join Date: Jun 2014
Location: Sioux Falls
Posts: 52
seneca leveler fuse

Today I got in a bad campsite, put the Bigfoot levelers down and the front wheels of my 2015 Seneca lifted off the ground.

I decided to retract and move but panel will not turn on. Both inside and ouside radios are dead, too. Fuse in bedroom panel for radio is OK as is radio fuse in main panel under hood. Is there another place to check.

Is there fuse for leveler and location?

Thanks

Foster15
__________________

Foster15 is offline   Reply With Quote
Old 03-01-2015, 08:03 PM   #2
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,041
Check behind the kick panel on the drivers side. There were several fuses and wiring connections there on our 08 SENECA.
__________________

__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is online now   Reply With Quote
Old 03-02-2015, 05:59 AM   #3
Member
 
Join Date: Aug 2013
Location: Detroit area
Posts: 35
I have a 2014 Seneca. Not sure if this will help but there are more fuses under the drivers seat behind the little skirt of the chair. Would be nice if we can get a " map'' of where are the fuses are. Does anyone know if Jayco has such a " map " ?
__________________
Chuck and The Boys
ci4mynewf is offline   Reply With Quote
Old 03-02-2015, 06:17 PM   #4
Member
 
Join Date: Jun 2014
Location: Sioux Falls
Posts: 52
Hi All. My dealer, Hilltop Sales Fridley, Mn, was very helpfull. With the clues I gave them they directed me to two fuses on a "switch" located in the chassis battery bin. Sure enough, one, the 7.5 amp was burned out. Replaced and all was good.

Foster 15
Foster15 is offline   Reply With Quote
Old 03-02-2015, 11:55 PM   #5
Member
 
meyerjohnc's Avatar
 
Join Date: Sep 2014
Location: Mulino
Posts: 46

We had the same issue on our first trip out in our 2015 Seneca out in themiddle of nowhere. Dealer had no clue but luckily roadside assistance newexactly what the issue was, same fuse at the chassis battery.


meyerjohnc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.