Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-05-2014, 10:47 AM   #1
Member
 
Join Date: Jun 2014
Location: Sioux Falls
Posts: 52
Seneca microwave/water heater

HI All. My wife and I recently purchased a 2015 Seneca and have two issues. The tankless water heater has failed us twice. The first issue was simply the igniter falling out of its bracket. For the second we are going to the dealer this week for a fix. Could it be the pressure? I use a 45 PSI limiter and have added a second water filter. Maybe not getting required water pressure.

Also, The microwave has an irritating rattle. It seems to be from inside the unit rather than being loose in the way it was hung. Any thoughts?

Thanks,

Foster15
__________________

Foster15 is offline   Reply With Quote
Old 10-05-2014, 11:27 AM   #2
Lost in the Woods
 
Join Date: Jun 2014
Location: Woodstock
Posts: 1,128
remove the pressure regulator and try it.

maybe the turntable is not sitting properly....it is the only thing moving to make noise
__________________

nbhybrid is offline   Reply With Quote
Old 10-05-2014, 04:10 PM   #3
Member
 
RULazy2's Avatar
 
Join Date: Jul 2014
Location: Anderson Creek, NC
Posts: 45
What is going on with your water heater? There has been a lot of discussion around these forums reference the Girard water heater and several "fixes" for them.
__________________
2014 Seneca 37FS, 2012 Mazda2 on a Master Tow dolly
RULazy2 is offline   Reply With Quote
Old 10-05-2014, 05:58 PM   #4
Member
 
Join Date: Jun 2014
Location: Sioux Falls
Posts: 52
RULazy2: I agree. There has been a lot of discussion on this topic. My first problem was probably an aberration; the igniter dropped out of its bracket. This time we camped for five nights; the first three nights the tankless heater worked. Then it stopped heating. We did not move the RV but I did switch between city water and normal "tank" water using the 12v pump. Not sure if that was an issue or not.

I will be back to the dealer this week.

Foster15
Foster15 is offline   Reply With Quote
Old 10-05-2014, 06:05 PM   #5
Lost in the Woods
 
Join Date: Jun 2014
Location: Woodstock
Posts: 1,128
did you remove the regulator and try it like i said above?
nbhybrid is offline   Reply With Quote
Old 10-05-2014, 07:15 PM   #6
Member
 
Join Date: Jun 2014
Location: Sioux Falls
Posts: 52
I have not had a chance to try your suggestion. I know when I had trouble the heater did not work on city water or on the 12v pump; two different pressures.

I will know more mid week.
Foster15 is offline   Reply With Quote
Old 10-05-2014, 08:04 PM   #7
Member
 
RULazy2's Avatar
 
Join Date: Jul 2014
Location: Anderson Creek, NC
Posts: 45
Weird issue. My FIL reported some trouble with his water heater as well. It worked well enough after he reset the heater itself. I will have to get with him and see what his dealer did to fix it.
__________________
2014 Seneca 37FS, 2012 Mazda2 on a Master Tow dolly
RULazy2 is offline   Reply With Quote
Old 10-06-2014, 09:10 PM   #8
Member
 
Join Date: Oct 2014
Location: Duncanville
Posts: 51
Send a message via Skype™ to Dave_Jan
My Bride and I just purchased a 2014 Seneca and are having an issue with the tankless water heater as well. Returning the dealer on the 17th is see whats up. Had our Grands with us for our first trip with this RV and no hot water did not help matters any.
Dave_Jan is offline   Reply With Quote
Old 10-07-2014, 05:02 PM   #9
Senior Member
 
D&MAKAFUN's Avatar
 
Join Date: Jul 2014
Location: KC MO
Posts: 358
If you had hot water 3 days and then nothing, the WH may have shut down due to it reaching the "too hot" level. There have been others that have had a similar issue and they pushed the reset button located in the WH box. If you have the dial in the bath be sure the setting is not on the highest setting. We have ours set in the 1 o'clock position now. During the warmer months we had it set just above the "low flame" mark. In other posts on this same subject posters have noted they called Girard 866-559-1221. Very positive customer service and walked poster through finding the reset button and all was good.
Best to you. The system does work very well..........just a matter of getting acquainted with the difference.
You didn't say if the microwave rattle was while you are in transit. Plate and roller ring will definitely do some moving around like nbhybrid noted.
Darrell
__________________
Darrell, Mary & K.C. Toller Mix
In our hearts: Goldens, Tess & Jericho
'15 Jayco Precept 31 UL "Bertha"
'13 Wrangler Sahara...AKAFUN
Roadmaster base plate
Ready Brute Elite towbar and brake combo
D&MAKAFUN is offline   Reply With Quote
Old 10-08-2014, 03:51 PM   #10
Junior Member
 
Join Date: Oct 2014
Location: La Center
Posts: 2
My wife and I just purchased a 2015 Greyhawk 29MV and took it out last weekend for the first time. Water heater worked great the first day, then quit. Called the dealer, they had no idea and suggested we bring it in. Decided to call Girard and ask. The tech guy was very helpful. He had me check the reset button in the WH box that Darrell mentioned in the earlier post and that fixed the problem once we reset it. He also told us to adjust our water temp with the dial and not so much with cold water. Quick and easy fix and it saved a trip back to the dealer.
Hope this helps.
__________________

RBDSM3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.