Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-11-2013, 05:44 AM   #1
Junior Member
 
Join Date: May 2013
Location: Illinois
Posts: 13
steel an

Took my 2006 Greyhawk on first outing. I noticed a whining noise when I would make left turns in city driving. It makes the same sound when the wheel is returned to center. Has anyone had this issue? It sounds like power steering issue. I checked the fluid level and it was fine.
__________________

steelman is offline   Reply With Quote
Old 06-11-2013, 09:36 PM   #2
Member
 
Join Date: Mar 2013
Location: Weddington, NC
Posts: 59
Nope
__________________

__________________
Bob & Sherri

2011 Jayco 31FK, Ford, Class C
2009 Honda CRV - Toad
Blue Ox Tow Bar
Invisibrake
Outdoor Kitchen Mod
Bobsanchez44 is offline   Reply With Quote
Old 06-12-2013, 01:16 PM   #3
Senior Member
 
Join Date: May 2013
Posts: 123
City driving means slow and lots of turning deflection?
I assume it'll whine if you turn left while the coach is stationary also? I think you're right with the power steering.
Some amount of whine or strain is normal.. If it's loud, I'd have it checked out... Almost certainly the pump.
cb1000rider is offline   Reply With Quote
Old 06-12-2013, 04:29 PM   #4
Senior Member
 
TX_Arvee's Avatar
 
Join Date: May 2012
Location: Pearland, TX
Posts: 514
I would say it is the power steering pump. If at idle and in park, will the sound dimminish if you rev the engine to a slightly higher RPM? The pump is under the most strain when at idle and when steering is turned greatly and vehicle is not in motion. Is pump on it's own pulley and belt or part of the serpentine belt system? Is the belt tight and in good condition? Is the fluid contaminated with water? If everything is good, you may be looking at a new PS pump..
TX_Arvee is offline   Reply With Quote
Old 06-12-2013, 06:11 PM   #5
Junior Member
 
Join Date: May 2013
Location: Illinois
Posts: 13
Taking it to the dealership tomorrow. The noise is not noticeable at highway speeds. This is a 2006 Greyhawk with 6,000 miles so I think it sat for most of its life. I,ll post what the problem turns out to be.
steelman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.