Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-02-2015, 10:32 AM   #1
Senior Member
 
JohnWedell's Avatar
 
Join Date: Sep 2015
Location: East Moriches
Posts: 309
Electrical help needed

Bought a 2015 285fb in January and had nothing but problems. The latest one is a dead short that burned open. The outlets on both sides of the bed are dead. Starcraft is useless, they keep sending me wiring diagrams of this unit when it had an outside kitchen and doesn't jive with the current floor plan. And everyone there is clueless. The fridge, living room tv, bedroom tv and outlet in the headboard are working but have no clue how the other 2 outlets wiring is run. any help would be appreciated. The dealer can't help because he can't get the right wiring diagram either.
__________________

JohnWedell is offline   Reply With Quote
Old 10-02-2015, 10:43 AM   #2
Senior Member
 
Wrascal's Avatar
 
Join Date: Oct 2014
Location: Lower Alabama (LA)
Posts: 1,918
You're not giving us much to help you with but I would suggest first totally powering down. Then go to the dead outlets and open them up. Look for frayed wires, etc within the outlet. Remove the outlets as one of them may be bad internally. Do this on all dead spots. If nothing obvious, next up, assuming it all worked when new, I would look at all areas that have movement (slides, etc) and see if there are any pinched wires. If still nothing obvious I would reset breakers and again apply power. If still tripping I'd reinstall the previous removed outlets. If power stayed on I'd replace one outlet at a time and try powering up each time.

Additionally, it may be the breaker and/or a ground fault outlet that's bad.

This is all just kind of generic BUT I don't understand why your dealer isn't trying these basic troubleshooting things.
__________________

__________________
2008 Jayco Eagle SuperLite 29.5
2014 F250 6.7 PSD 4X4, CC LB
Wrascal is offline   Reply With Quote
Old 10-02-2015, 10:52 AM   #3
Senior Member
 
JohnWedell's Avatar
 
Join Date: Sep 2015
Location: East Moriches
Posts: 309
Quote:
Originally Posted by Wrascal View Post
You're not giving us much to help you with but I would suggest first totally powering down. Then go to the dead outlets and open them up. Look for frayed wires, etc within the outlet. Remove the outlets as one of them may be bad internally. Do this on all dead spots. If nothing obvious, next up, assuming it all worked when new, I would look at all areas that have movement (slides, etc) and see if there are any pinched wires. If still nothing obvious I would reset breakers and again apply power. If still tripping I'd reinstall the previous removed outlets. If power stayed on I'd replace one outlet at a time and try powering up each time.

This is all just kind of generic BUT I don't understand why your dealer isn't trying these basic troubleshooting things.
Appreciate your reply. I'm a licensed electrician and checked everything I could. The breaker doesn't trip any more because the circuit is burned open. I used my wire tracer to trace out the circuit but that didn't help. Have no idea if there is a junction box in the belly. Slides are not an issue. With the proper wiring diagram I could find the problem in minutes.
JohnWedell is offline   Reply With Quote
Old 10-02-2015, 11:05 AM   #4
Senior Member
 
Join Date: May 2015
Location: Ottawa
Posts: 136
Did you provide them the serial number when asking for the diagrams, I know that Jayco usually asks for this to get the correct files sent.
__________________
2011 Swift SLX 154bh /2012 Rav4 V6 with airbags & 15k btu transmission cooler.
km counter: 1700
octane is offline   Reply With Quote
Old 10-02-2015, 11:10 AM   #5
Senior Member
 
JohnWedell's Avatar
 
Join Date: Sep 2015
Location: East Moriches
Posts: 309
Both the dealer and I gave them the serial number and. I kept telling them the diagram was wrong but they just don't get it.
JohnWedell is offline   Reply With Quote
Old 10-06-2015, 04:17 PM   #6
Senior Member
 
JohnWedell's Avatar
 
Join Date: Sep 2015
Location: East Moriches
Posts: 309
Update:
Wire was run through the underbelly and pinched and burned in two places. Now I'm nervous ��
JohnWedell is offline   Reply With Quote
Old 10-07-2015, 07:06 AM   #7
Senior Member
 
pawpaw's Avatar
 
Join Date: Jul 2013
Location: Cypress, TX
Posts: 307
That's scary but I'm glad you found the problem. Hopefully that'll be the end of your troubles.
__________________

2014 GMC Sierra 4x4 crew cab with 6.2L and max tow package
2015 Starcraft Autumn Ridge 329BHU
2015 Starcraft AR-One 18QB
2014 JayFlight Swift 264BH - SOLD!
2013 Skyline Bobcat 162B - SOLD!
Cypress, TX
pawpaw is offline   Reply With Quote
Old 10-07-2015, 07:42 AM   #8
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,032
Good work finding the problem. Hope that was all the electric trouble you have. Time will tell.
I'm thinking the diagram may have helped but it may not have been detailed enough to put you right on the actual wiring routing.
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is online now   Reply With Quote
Old 10-10-2015, 12:21 PM   #9
Senior Member
 
JohnWedell's Avatar
 
Join Date: Sep 2015
Location: East Moriches
Posts: 309
Update:
After DW seen the burned wiring she refuses to go back in the trailer.

Solution:
In 3 weeks will take delivery of a 2016 Jayco Eagle 338rets.

Unintended consequences:
Had to buy a 1 ton truck to tow it.

Outcome:
Happy Wife, Happy Life!
JohnWedell is offline   Reply With Quote
Old 10-10-2015, 05:50 PM   #10
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,032
Sounds like a win win!
__________________

__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.