Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2022, 07:34 PM   #1
Member
 
Join Date: Sep 2020
Location: Greer
Posts: 35
2020 Jayco 355MBQS

I notice this evening that the running lights were on even when the battery was cut off. What am I missing here? It took me to take the cable off the battery post before thy would go out. This has never happened before. Any ideas?
81greer is offline   Reply With Quote
Old 03-27-2022, 09:18 AM   #2
Senior Member
 
Join Date: Jun 2018
Location: VULCAN
Posts: 684
Quote:
Originally Posted by 81greer View Post
I notice this evening that the running lights were on even when the battery was cut off. What am I missing here? It took me to take the cable off the battery post before thy would go out. This has never happened before. Any ideas?
Something similar happened on my 2022 Eagle 28.5 last fall. Running lights and tail lights were staying on, I was disconnected from the truck 7 way. Also disconnected from shore power. Also disconnected the batteries. Running lights still on. Looked for the solar disconnect, surprise. There isn't one according to Jayco service who was trying to help me over the phone. With a lot of searching 2000 miles from home, I found a problem in the 4 square junction box where the 7 way cord from the truck cord branches out. It's up by the pin box, a couple of screws and the cover comes off. There was a short in the wiring.


Always carry a multi meter. This is an absolute must, if you don't know how to use one, someone else will, to help you out.
__________________
2019 Ram 2500 Cummins

2022 Jayco 28.5 RSTS
Yooper906 is offline   Reply With Quote
Old 03-27-2022, 09:27 AM   #3
Member
 
Join Date: Sep 2020
Location: Greer
Posts: 35
I had some else tell me it could be in the 7 way plug.
Thanks for the info.
I use a hitch vest when I’m not using the camper. Maybe that hs something to do with it in shorting it out.
Thanks again
81greer is offline   Reply With Quote
Old 03-27-2022, 10:02 AM   #4
Senior Member
 
Join Date: Jun 2018
Location: VULCAN
Posts: 684
Quote:
Originally Posted by 81greer View Post
I had some else tell me it could be in the 7 way plug.
Thanks for the info.
I use a hitch vest when Iím not using the camper. Maybe that hs something to do with it in shorting it out.
Thanks again
Most likely not in the plug itself, but in the junction box by the pin box. Mine happened when unplugged from the truck.
__________________
2019 Ram 2500 Cummins

2022 Jayco 28.5 RSTS
Yooper906 is offline   Reply With Quote
Old 03-27-2022, 11:58 AM   #5
Member
 
Join Date: Sep 2020
Location: Greer
Posts: 35
Thanks so much
81greer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.