Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 03-16-2018, 10:15 AM   #1
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Atwood furnace issue

So our furnace wonít fire. Specifically the blower will run but we have no ignition. Iíve read about a reset button but we couldnít find one. If anyone has troubleshooting suggestions they are appreciated. Thank you


Sent from my iPhone using Tapatalk
__________________

__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Old 03-16-2018, 10:21 AM   #2
Senior Member
 
Join Date: May 2014
Location: OKC
Posts: 342
First I would check the LP gas tanks to make sure they have gas and are open.

Then I would run the gas range to prove to myself that the gas is turned on and working.

Then I would try the furnace again. If still no light, I would take in for warranty repair.
__________________

__________________
2016 Road Warrior 355
2015 Ram 3500 Cummins SRW 4x4 MegaCab ShortBed
2011 F150 ecoboost - Traded
2015 Jayflight 28 BHBE (sold)
2009 Jayflight 26 BH (sold)
hboy is offline   Reply With Quote
Old 03-16-2018, 10:57 AM   #3
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Tanks are full. Range working normally. Thanks though for input.


Sent from my iPhone using Tapatalk
__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Old 03-16-2018, 11:39 AM   #4
Senior Member
 
Iraqvet05's Avatar
 
Join Date: Mar 2013
Location: Kansas City
Posts: 1,303
The reset switch on my Atwood was on top of the furnace housing. I had to remove my sofa and the covering around the furnace to get to it.
__________________
2013 26BH w/ 4 plain rims and some rust
2017 Ford F250 XLT, 6.2 gasser
Iraqvet05 is offline   Reply With Quote
Old 03-16-2018, 02:15 PM   #5
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Roger Iraqvet, thanks for that tip and your service.


Sent from my iPhone using Tapatalk
__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Old 03-16-2018, 08:18 PM   #6
Senior Member
 
Join Date: Jun 2015
Location: smithville, ont.
Posts: 1,901
The reset is a glorified on/off/breaker switch....if it trips then you would have no blower.
I read in the manual about pulling the fuse (or just killing the coach power) for a “reset”
__________________
2016 North Point 341RLTS
520watts of solar. Morningstar MPPT
2017 F-350 Platinum CC SRW
klassic is offline   Reply With Quote
Old 03-17-2018, 05:21 AM   #7
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Well Klassic you saved me some time as my blower does operate. Weíre leaving Bradenton tomorrow morning heading to Gulf Shores AL. There is an Atwood authorized mobile service 10 miles from our campground so I think Iíll be giving them a call. Thanks all for your input.


Sent from my iPhone using Tapatalk
__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Old 03-18-2018, 07:58 AM   #8
Senior Member
 
MadJoker TX's Avatar
 
Join Date: Mar 2017
Location: Missouri City
Posts: 262
Quote:
Originally Posted by Doubleheader View Post
Well Klassic you saved me some time as my blower does operate. Weíre leaving Bradenton tomorrow morning heading to Gulf Shores AL. There is an Atwood authorized mobile service 10 miles from our campground so I think Iíll be giving them a call. Thanks all for your input.


Sent from my iPhone using Tapatalk
Let us know what they say as I have the same issues in my 377

Sent from my SAMSUNG-SM-G930A using Tapatalk
__________________
____________________
2017 Ford F350 FX4 DRW
2017 NorthPoint 377RLBH
MadJoker TX is offline   Reply With Quote
Old 03-18-2018, 09:04 AM   #9
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Will do. It may be a couple days but I will post an update.


Sent from my iPhone using Tapatalk
__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Old 03-20-2018, 06:27 AM   #10
Senior Member
 
Doubleheader's Avatar
 
Join Date: Feb 2017
Location: Warren
Posts: 201
Now Iím perplexed. I have scheduled an Atwood tech for next week, but just for giggles I tried the furnace this morning and it fired right up. We traveled almost 500 miles in the last two days and Iím thinking that perhaps I had some type of blockage in the burner orifice that dislodged during travel. Iíll try it a few more times before I cancel my tech.


Sent from my iPhone using Tapatalk
__________________

__________________
2014 Ram 2500 Cummins
2018 Eagle 293RKDS
Doubleheader is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.