Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-15-2020, 10:38 PM   #1
Junior Member
 
Join Date: Jul 2017
Location: Redding
Posts: 14
Charging system

A friend has been having an issue with his charging system from his tow vehicle (2012 Ford Superduty). We tested the system and the vehicle is putting out 13.5 to 14.2 to the plug. In the battery area there is a buss bar that the charge circuit from the pickup power goes to. With the charge wire connected to this area I get 12.4 volts. When removed the voltage of this wire goes back to 13.5 + voltage. If i take this wire directly to the battery + post the voltage drops again. Any help would be appreciated. Thanks
Dsykes is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.