Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-07-2015, 11:25 PM   #11
Member
 
Join Date: Jul 2015
Location: Grand rapids
Posts: 36
Quote:
Originally Posted by tnchuck100 View Post
Boy, Jayco quality is sure getting some bad press lately. I have seen a tremendous increase in quality complaints here in the last year.
Well, your not kidding that's for sure, follow along and watch it. This weekend I had yet another surprise. Water dripping from the ceiling from condensation on the AC.

Hmmm. Water, on ceiling and the AC is above, wonder what's going on in the middle.
__________________

Trackermi is offline   Reply With Quote
Old 09-08-2015, 06:14 AM   #12
Senior Member
 
Join Date: Jun 2013
Location: Camp Hill
Posts: 239
Maybe, the retaining bolts of the a/c unit are loose. Mine were all loose with one hanging freely. These are bolts that must be inspected and snugged up regularly.

The original install of mine must have straddled lunch or quitting time.
__________________

__________________
2013 Jayco X23B
Solar System: Renogy 300W/Tristar 45 PWM
DC System: Trojan T-105 225 AH/Samlex PST-600 PSW
2013 RAM 1500 V6/TF8/3.55
sebring96hbg is offline   Reply With Quote
Old 09-08-2015, 08:42 AM   #13
Member
 
Join Date: Jul 2015
Location: Grand rapids
Posts: 36
Quote:
Originally Posted by sebring96hbg View Post
Maybe, the retaining bolts of the a/c unit are loose. Mine were all loose with one hanging freely. These are bolts that must be inspected and snugged up regularly.

The original install of mine must have straddled lunch or quitting time.

I will have to jump up there tonight and take a look @ the AC. The unit we have is one of those quiet version, so the only thing I see on the inside are the ducts. I am curious if the duct is so close to the ceiling and is missing some kind of insulation or protective foam like they do for AC units in residential. Then the sheer coldness of the duct causes the roof to condensate.
Trackermi is offline   Reply With Quote
Old 09-08-2015, 09:37 AM   #14
Junior Member
 
Join Date: Nov 2013
Location: Prescott
Posts: 12
Well guest what we China tires. :.(.
Wjbuckler is offline   Reply With Quote
Old 09-08-2015, 10:24 AM   #15
Senior Member
 
troutslayer's Avatar
 
Join Date: Dec 2012
Location: NW AR (God's Country)
Posts: 1,846
I had 4 new General tires put on my truck last Spring and had a severe bounce between 50 and 55 mph. Took them in to be re-balanced three times. They finally said that two of the tires could not be balanced due to defects, so I went with another tire brand. That was three months ago and I'm still waiting on General for the refund.
__________________

__________________
Skip

2012 Eagle Super Lite HT 26.5RKS
2005 GMC 2500 SLT HD D/A
troutslayer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 10:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.