Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-18-2020, 09:11 PM   #1
Junior Member
 
Join Date: Sep 2019
Location: Griswold
Posts: 8
Dinette light not working

I have a 2015 pinnacle 38flsa. The dinette light does not come on. I pushed the little switch on the chandelier but nothing happens. What am I missing? Is there another switch somewhere?
fchaluto is offline   Reply With Quote
Old 03-18-2020, 09:27 PM   #2
Site Team
 
JFlightRisk's Avatar
 
Join Date: Apr 2012
Location: Newark, NY
Posts: 8,945
Are there any other ceiling lights not working? We have a completely different Jayco, and our dinette light, and one other double bulb light are the only items on that fuse. There's also the possibility the bulb(s) are blown, or the switch went bad.
__________________
Every day's a learning experience, though sometimes not what we expected.

2012 Jay Flight 19RD
2016 Ford F150 XLT 2X4 SC 3.5L Eco Max Tow
2010 Tundra TRD DBL Cab (Traded)
1 Spoiled Dog
JFlightRisk is offline   Reply With Quote
Old 03-19-2020, 05:55 AM   #3
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: James Island, SC
Posts: 18,642
It has to be a simple trouble.

Remove the couple of screws holding the fixture up and verify the switch, voltage 12 vdc and ground connections. Even the bulb can be bad in a new unit. Mine is a lot older but when we first got the rig, I had my dealer order a fixture to match others and we have been very happy with it. It was not defective but kept loosening up and falling apart.

Good luck finding it!
__________________
Moderator
2011- 351RLTS Eagle, MorRyde suspension/pin box,
2017- F350 6.7 PSD Lariat FX4,SRW, SB,CC
Hughes PWD SP-50A, TST TPMS
Gator roll-up bed cover
B&W Turnover ball, Andersen Ultimate 3220
Can't find what you're looking on JOF? Try Jayco Owners Forum Custom Google Search
norty1 is offline   Reply With Quote
Old 03-29-2020, 08:16 AM   #4
Junior Member
 
Join Date: Sep 2019
Location: Griswold
Posts: 8
Found the problem. It was a fuse, thanks for the feedback
fchaluto is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.