Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-05-2014, 06:36 PM   #11
Junior Member
 
Join Date: Dec 2013
Posts: 21
One more...went to the trailer this weekend to pull it out of its winter site and the furnace fired right up and worked through the night without issue. It seems to be that whenever its freezing (below 25'ish) it doesn't work.
Its at the dealer now..more to follow.
__________________

FiverForUs is offline   Reply With Quote
Old 04-20-2014, 09:52 AM   #12
Junior Member
 
Join Date: Dec 2013
Posts: 21
UPDATE:
Finally got it out of the snow and got it to camping world. By the way, they have actually been wonderful through the entire ordeal. They are replacing the regulator (again), the manifold and some hoses. I'll update again as soon as I hear what the final answer is but at least they are throwing parts at it.

What and where is the manifold? I thought the manifold/regulator where the same animal.
__________________

FiverForUs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.