Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 09-14-2021, 11:03 PM   #1
Junior Member
 
Join Date: Jun 2021
Location: Prescott
Posts: 7
Ground Control 3 Issue?

Hello All! Have a 2022 28.5 RSTS. Was getting ready for a short trip and tried to extend the rear jacks with the BMPRO, The left one works but the right one acts like it's working but says excessive angle and does nothing. Then noticed the left front jack says the same thing and won't move from the BMPRO panel or app. So the the right front and left rear work, but the left front and right rear do not. I checked all connections and fuses. The left front jack works fine using the lippert panel in the basement. Any suggestions on what to check? Thank you!
Atcla is offline   Reply With Quote
Old 09-15-2021, 03:34 AM   #2
Member
 
Stan&Sharon's Avatar
 
Join Date: Apr 2021
Location: New Hampshire
Posts: 84
It's common for the basement and inside controller/phone software to work, or not, differently. Usually as I've seen in this forum, the basement doesn't always work but BMPro does. That's how my 5er is. Sometimes the basement works and sometimes not. The phone app and BMP always works for me.

I recently learned the BMPro panel inside is actually a google android tablet. Connect it to the internet then bring up the google playstore on it, look to update the software like you would any android. Yesterday I found many things that needed updates. Hopefully you just need an update.

Look at the bottom of the screen for the standard android menu controls. These look sort of like the image below. Press the middle one to return to home page, then swipe down from the top right to get to settings to connect it to the internet.


After your updates, then launch the BMPro app and try it again.

Here's a Help Guide that shows how to 'clear app data' https://teambmpro.com/wp-content/upl...g-App-Data.pdf
__________________
2022 Eagle 321RSTS w/Overlander II solar
2021 GMC Denali 2500HD Gas w/Timbrens
Pullrite SuperRails, Pullrite SuperLite hitch
Stan&Sharon is offline   Reply With Quote
Old 09-15-2021, 03:57 AM   #3
Member
 
Stan&Sharon's Avatar
 
Join Date: Apr 2021
Location: New Hampshire
Posts: 84
My first time setup, my 5er didn't level correctly. No big deal, just use the controls (or BMPro app) to level her out using a common carpenter's leveler. Then using BMPro menu, there's the option to tell BMPro "This is what I want when I press 'AUTO LEVEL' ".

Next time I tried it, it worked perfectly. I just needed to teach it what 'level' means.
__________________
2022 Eagle 321RSTS w/Overlander II solar
2021 GMC Denali 2500HD Gas w/Timbrens
Pullrite SuperRails, Pullrite SuperLite hitch
Stan&Sharon is offline   Reply With Quote
Old 09-15-2021, 06:37 AM   #4
Junior Member
 
Join Date: Jun 2021
Location: Prescott
Posts: 7
Thank you! I'll give that shot and see what happens!
Atcla is offline   Reply With Quote
Old 09-15-2021, 06:38 AM   #5
Member
 
Join Date: Mar 2021
Location: North Ridgeville
Posts: 30
I had an issue I could not get the jacks to move. I retracted all jacks until they were all up. Then everything worked fine. This happened to me twice.

Also i had the same issue of not being level when it said it was. Did the same as Stan&Sharon.
Toolguy5 is offline   Reply With Quote
Old 09-16-2021, 04:28 AM   #6
Senior Member
 
jetlag's Avatar
 
Join Date: May 2021
Location: Vanceboro
Posts: 417
It happened to us at home, new rig and very confused as it wouldn't auto level. Went to the Equalizer quick start page, and first thing it said was if the rear legs red lights were on, push retract all legs and let it do its thing. Then push auto level. Worked like a charm.
__________________
2021 Ram Laramie 3500 SRW Air ride 50Gal fuel tank.
2021 Jayco Pinnacle 36FBTS, Andersen Ultimate Hitch
jetlag is offline   Reply With Quote
Old 09-16-2021, 07:45 AM   #7
Senior Member
 
Join Date: Aug 2018
Location: ridgecrest
Posts: 276
I noticed the same issue when lake shore camping. Even though i was using blocks, he excessive slope would throw off the leveling computer and not let it start. Once i got the coach in a fairly level position then the system started working. May not be your problem, but just a suggestion.
kirkelli is offline   Reply With Quote
Old 09-19-2021, 09:19 PM   #8
Junior Member
 
Join Date: Jun 2021
Location: Prescott
Posts: 7
Thank you everyone for your help! Had a family emergency and haven't had a chance to try your suggestions, but will sometime this week!
Atcla is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 06:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.