Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-30-2020, 03:41 PM   #1
Senior Member
 
rkymntsno's Avatar
 
Join Date: Feb 2019
Location: Schertz
Posts: 1,021
Help...Coleman Mach running but not cooling

Of course as luck would have it, just rolled into Houston. Setting up and turning on the air conditioners, and the bedroom A/C is blowing hot air. Is there any troubleshooting involved with these things? Breaker's fine as it's blowing hot air. Shut it off and on several times, no luck. Called Jayco, they wouldn't troubleshoot anything, just gave me phone numbers to call to see if anyone would come out and work on it in which I would have to pay them to do that. WTH???? Any advice out there?
__________________
2018 Ram 3500 CC Longhorn LB SRW w/timbrens
2019 Jayco Eagle 355MBQS
Pullrite 2600 Superlite
rkymntsno is offline   Reply With Quote
Old 10-30-2020, 03:51 PM   #2
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 16,248
JAYCO doesn't have ""SERVICE" techs for a/c units. It could be numerous issues which are impossible to figure out on the phone. Thermostat, loose connection, bad compressor. You need to call a mobile tech as they stated.
__________________
DISNEY LOVERS
Grumpy is offline   Reply With Quote
Old 10-30-2020, 03:54 PM   #3
Senior Member
 
rkymntsno's Avatar
 
Join Date: Feb 2019
Location: Schertz
Posts: 1,021
Quote:
Originally Posted by Grumpy View Post
JAYCO doesn't have ""SERVICE" techs for a/c units. It could be numerous issues which are impossible to figure out on the phone. Thermostat, loose connection, bad compressor. You need to call a mobile tech as they stated.
They do have techs that they were trying to get me to but they were busy.
__________________
2018 Ram 3500 CC Longhorn LB SRW w/timbrens
2019 Jayco Eagle 355MBQS
Pullrite 2600 Superlite
rkymntsno is offline   Reply With Quote
Old 10-30-2020, 04:22 PM   #4
Senior Member
 
Topperace's Avatar
 
Join Date: Feb 2020
Location: On The Move
Posts: 1,213
I have same problem with our front AC, compressor will kick on, but temp is same as outside temp...finally got appointment with dealer and they said AC bad, AC freon had leaked out... Coleman sending another unit to replace it...when
they get some made...big shortage of ACs, especially that model MACH 8 15kw.
Realize this doesn't help you, and hope it's not the same problem, but that was
what was wrong with ours.
__________________
S&T
2019 Entegra Insignia 37MB
2022 JEEP Wrangler 4xe (chase and touring vehicle)
(2019 NP 383FKWS)
(2019 RAM 3500 DRW Big Horn)
Topperace is offline   Reply With Quote
Old 10-30-2020, 05:53 PM   #5
Senior Member
 
rkymntsno's Avatar
 
Join Date: Feb 2019
Location: Schertz
Posts: 1,021
Quote:
Originally Posted by Topperace View Post
I have same problem with our front AC, compressor will kick on, but temp is same as outside temp...finally got appointment with dealer and they said AC bad, AC freon had leaked out... Coleman sending another unit to replace it...when
they get some made...big shortage of ACs, especially that model MACH 8 15kw.
Realize this doesn't help you, and hope it's not the same problem, but that was
what was wrong with ours.
I'm hoping it's just a capacitor. I had been noticing this past summer issues with the bedroom a/c where the compressor would kick on for a few seconds then shut off. We would have it on cool/high/on, not auto. But it would always eventually kick on and stay on to cool. At least it crapped out this time of season and if we're waiting on parts or a new a/c it's not in the spring or summer!
__________________
2018 Ram 3500 CC Longhorn LB SRW w/timbrens
2019 Jayco Eagle 355MBQS
Pullrite 2600 Superlite
rkymntsno is offline   Reply With Quote
Old 10-30-2020, 06:39 PM   #6
Senior Member
 
Mopar_Earl's Avatar
 
Join Date: Oct 2016
Location: Saint Thomas, PA
Posts: 2,234
If it's a low profile, is the condenser fan running? I had a tiny twig get in my condenser fan and lock it. Compressor over pressurized and would trip out.


Earl
__________________
2017 Eagle 293RKDS, factory ordered, lots of mods and upgrades. More than I can list.
2018 Ram 3500 crew cab long bed SRW diesel 6spd Aisin 4wd Tradesman.
B&W Ram puck 5th wheel
Line-X premium
Mopar wheel to wheel steps
Mopar_Earl is offline   Reply With Quote
Old 10-30-2020, 06:43 PM   #7
Senior Member
 
rkymntsno's Avatar
 
Join Date: Feb 2019
Location: Schertz
Posts: 1,021
Quote:
Originally Posted by Mopar_Earl View Post
If it's a low profile, is the condenser fan running? I had a tiny twig get in my condenser fan and lock it. Compressor over pressurized and would trip out.


Earl
Not sure. When I turn it on, the fan will run but compressor will not kick on.
__________________
2018 Ram 3500 CC Longhorn LB SRW w/timbrens
2019 Jayco Eagle 355MBQS
Pullrite 2600 Superlite
rkymntsno is offline   Reply With Quote
Old 11-01-2020, 12:46 PM   #8
Senior Member
 
Joan617's Avatar
 
Join Date: Nov 2018
Location: Las Cruces (soon...)
Posts: 802
We had ours stop cooling once and when I went to the roof and pulled the cover, I found the condenser frozen up. Let it melt off and then started cooling again but the fan would never shut off.


I was chagrined when the mobile tech showed up and promptly found a 3" construction screw in the plastic compartment holding the controller board. It had come to rest across the contacts for the fan. Maybe it moved when I was moving about the roof and pulling the shroud off. Go figure.


Angus
__________________
Joan & Angus Campbell
Winters in Las Cruces, NM, traveling the rest
2019 Pinnacle 36SSWS "Diana"
2019 F350 DRW Lariat CC Long Bed Diesel "Sheila"
3 Chihuahuas and 4 cats
We don't camp, we don't glamp, we LIVE.
Joan617 is offline   Reply With Quote
Old 11-10-2020, 07:34 PM   #9
Senior Member
 
Sola123's Avatar
 
Join Date: Oct 2018
Location: Shipman
Posts: 224
I had similar problem in Florida.....turned out to be a loose wire that must had come unplugged or never plugged in to start with....been fine since
__________________
Stan & Sandra
Shipman, VA. & Jacksonville FL.
2015 F350 Lariet CC Dually
2018 Pinnacle 36KPTS

Sola123 is offline   Reply With Quote
Old 11-11-2020, 07:54 AM   #10
Senior Member
 
rkymntsno's Avatar
 
Join Date: Feb 2019
Location: Schertz
Posts: 1,021
As it turns out, I took it to the dealership service and they checked it out. It's running fine. Well it didn't run in Houston.
__________________
2018 Ram 3500 CC Longhorn LB SRW w/timbrens
2019 Jayco Eagle 355MBQS
Pullrite 2600 Superlite
rkymntsno is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.