Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 02-14-2019, 06:49 AM   #1
Junior Member
 
Join Date: Jun 2018
Location: Clearwater
Posts: 7
Hot water heater LP

What is the red light for above the hot water heater switch for gas? As you can see we have both electric and gas.

Overnight I left the LP on and turn the electric off because we're boon docking. Woke up this morning in the light above the LP was on. And I have no hot water. So I turned on the electric as well.
Attached Thumbnails
20190214_074619.jpg  
__________________

Mako284 is offline   Reply With Quote
Old 02-14-2019, 09:53 AM   #2
Senior Member
 
NVGun40's Avatar
 
Join Date: Feb 2015
Location: Eagle River, AK
Posts: 835
Most I have seen that light is to indicate a failure in the ignition for the water heater.
Cycle the switch off, wait for about 10 seconds and turn it back on. Go and listen to the water heater and see if it ignites. If it ignites and burns well, it could have just been a fluke during the night. If it doesn't stay lit, there could be something additional: debris in the burn tube or at the gas nozzle; faulty ignitor; circuit board problem.
I am sure others can chime in with additional troubleshooting advice.
__________________

__________________
We are just a humble drinking couple with a hunting and camping problem.
2018 Jayco Octane 260
2004 Dodge Ram 2500, 5.7 Hemi, 5Spd Manual
2018 Argo Frontier 8x8/2008 Arctic Cat M1000 SnoPro
Previous: Komfort 5er/Jamboree MH/Lance Cabover/Jayco Whitehawk 25BHS TT
NVGun40 is offline   Reply With Quote
Old 02-14-2019, 10:05 AM   #3
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 2,103
Any chance the propane tank emptied and it didn't change over to another? Do other LP appliances still work OK?

If it doesn't relight after being cycled off/back on as mentioned it could also be a bad ignitor board if it is an Atwood HWH. Seems they had a significant number of them fail.
__________________
Rob R.
Akron, OH
2014 Seneca 37TS
Toads: 2014 Ford Explorer Sport or 2013 Ford Focus ST
Robbbyr is offline   Reply With Quote
Old 02-14-2019, 10:48 AM   #4
Senior Member
 
ALJO's Avatar
 
Join Date: Oct 2014
Location: Sparwood, BC
Posts: 2,159
Send a message via Skype™ to ALJO
Just turn off the gas operation switch and it will reset operation to normal
__________________
2014 Ram 1500 CrewCab 4x4 5.7 Hemi 3.92 Rear and Air Lift 1000
2005 Jayco Jay Feather LGT - 29Y GVWR-7000 lbs.
Dexter Axle Lift 4-9/16" - installed with sub-frame.
Pro Series 1200 lbs. WDH with Double Sway Bar.
Champion 3100/2800 watt Inverter/Generator-Onboard Solar Power
ALJO is offline   Reply With Quote
Old 02-14-2019, 11:22 AM   #5
Junior Member
 
Join Date: Jun 2018
Location: Clearwater
Posts: 7
Circuit board was bad -

Thanks for the feedback -

limited hot water from the electric side (Luke warm), no ignition (with a lighter, if I killed the power then back on a lighter would ignite the flame and a second later it would click and go out) from the LP side.

The red light does mean failure....

Swapped the board and wala... magic...

My learning for the day is done, time for a beer!
Mako284 is offline   Reply With Quote
Old 02-14-2019, 11:35 AM   #6
Senior Member
 
AKRUEBBE's Avatar
 
Join Date: Apr 2018
Location: Sequim, WA until April 30th
Posts: 385
Quote:
Originally Posted by Mako284 View Post
Circuit board was bad -

Thanks for the feedback -

limited hot water from the electric side (Luke warm), no ignition (with a lighter, if I killed the power then back on a lighter would ignite the flame and a second later it would click and go out) from the LP side.

The red light does mean failure....

Swapped the board and wala... magic...

My learning for the day is done, time for a beer!
Did you test the circuit board with an amp meter? Just curious.
__________________
2018 NORTH POINT 315RLTS
2017 RAM 3500 DRW DIESEL/AISIN 4.10 AIR BAGS
B&W COMPANION TURN OVER BALL HITCH
AKRUEBBE is offline   Reply With Quote
Old 02-14-2019, 12:04 PM   #7
Senior Member
 
Robbbyr's Avatar
 
Join Date: Dec 2014
Location: Akron
Posts: 2,103
Quote:
Originally Posted by Mako284 View Post
Circuit board was bad -

Thanks for the feedback -

limited hot water from the electric side (Luke warm), no ignition (with a lighter, if I killed the power then back on a lighter would ignite the flame and a second later it would click and go out) from the LP side.

The red light does mean failure....

Swapped the board and wala... magic...

My learning for the day is done, time for a beer!
Glad it is working again, I carry a spare board with me because of the issue.
__________________
Rob R.
Akron, OH
2014 Seneca 37TS
Toads: 2014 Ford Explorer Sport or 2013 Ford Focus ST
Robbbyr is offline   Reply With Quote
Old 02-14-2019, 08:09 PM   #8
Member
 
Join Date: Nov 2018
Location: Brunswick GA
Posts: 60
Our circuit board went too on the second month after purchase. The clue for me was that after seeing the 2 amp mini fuse on the board blown, then the replacement fuse blew right away.
Dometic sent me a new board right away under warranty and advised me to look on line at Amazon for backup replacements for less than the $200 that they would have charged with shipping for an out-of-pocket spare. Depending on the part number of the board you can get them for about $120 as OEM or used on eBay for $80-$100 for “used but from new units otherwise damaged” (my paraphrasing).

I’ve decided to buy a spare based on other comments here. Cold showers in the morning suck, even if you can walk to the camp’s facility
__________________
Joan & Angus Campbell
Brunswick GA
Pinnacle 36SSWS
F350 DRW Lariat CC Long Bed Diesel "Sheila"
Joan617 is offline   Reply With Quote
Old 02-14-2019, 08:14 PM   #9
Senior Member
 
AKRUEBBE's Avatar
 
Join Date: Apr 2018
Location: Sequim, WA until April 30th
Posts: 385
Quote:
Originally Posted by Joan617 View Post
Our circuit board went too on the second month after purchase. The clue for me was that after seeing the 2 amp mini fuse on the board blown, the replacement fuse blew
Right away.
Dometic sent me a new board right away under warranty and advised me to look on line at Amazon for backup replacements for less than the $200 that they would have charged with shipping for an out-of-pocket spare. Depending on the part number of the board you can get them for about $120 as OEM or used on eBay for $80-$100 for ďused but from new units otherwise damagedĒ (my paraphrasing).

Iíve decided to buy a spare based on other comments here. Cold showers in the morning suck, even if you can walk to the campís facility
When our new Pinnacle arrives I will check the water heater brand and model number and definitely order a spare board!!
__________________
2018 NORTH POINT 315RLTS
2017 RAM 3500 DRW DIESEL/AISIN 4.10 AIR BAGS
B&W COMPANION TURN OVER BALL HITCH
AKRUEBBE is offline   Reply With Quote
Old 02-14-2019, 08:43 PM   #10
Senior Member
 
Join Date: Aug 2011
Location: Missouri City, The Republic of Texas
Posts: 3,596
Any idea what the soft point is? Is the board 12V only or does it also handle the 110 side (thinking spike or low voltage on AC side)? Water contact? This seems to be a not uncommon failure.
__________________

__________________
Cheers,
T_

2013 F-350 CC SB 2WD 6.7PS
2013 Eagle Premier 351 RLTS
-SOLD- 2012 X23B
-SOLD- 2003 Ford Expedition 5.4, Bilstein shocks
RedHorse1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.