Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-21-2015, 03:48 PM   #1
Junior Member
 
Join Date: Jun 2015
Location: Jackson
Posts: 4
Jayco Eagle 325 BHQS tank flush labeled wrong.

Just trying to save someone else the headache we just went through. Our toilet got stopped up while we were camping. We used a plunger and it came unclogged, but then our black tank wouldn't drain. We went out and bought a flush king (as per suggestions we found online). Nothing worked. We couldn't get it to drain at all. My husband just decided to go ahead and dump the grey tanks too. Since we had to flush king hooked up we seen that the sewage was what was "finally" coming out! At 1st we thought it was coincidence, but while we had the black tank flush turned on we shut off what was supposed to be the black tank gate and the black tank was still flushing through. They were labeled wrong from the factory. Had we not had the flush king we would've never known that it was actually sewage coming out of what was supposed to grey water. Glad it was nothing major, but it was a lot of time wasted trying to fix it! It more than likely originally got stopped up because when we thought we were draining to grey tank, we were actually draining to black. So we weren't putting the water back in the tank like we were supposed to... Because we didn't know that it was drained...
__________________

jjmauer is offline   Reply With Quote
Old 06-21-2015, 07:04 PM   #2
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,047
Hard lesson. I have found it is a good idea to verify the labels on a new rig to verify what took you so long to find.

The grey tanks indicators inside just say grey1 and grey 2. It is good and easy to check them and mark them so there is no confusion.
I had one marked wrong on another brand rig.

A clear connector on the sewer hose outlet is a great help to see what and when the tank is done dumping.
__________________

__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 06-21-2015, 07:35 PM   #3
Junior Member
 
Join Date: Jun 2015
Location: Jackson
Posts: 4
We love our Jayco camper! We have had a couple other brands, and our jayco seems very well built! I just wanted to mention this incase someone else is ever "googling" the same questions we had. Every post we found just said it was probably a clog. So glad we found the problem, and it was nothing serious.
jjmauer is offline   Reply With Quote
Old 06-22-2015, 05:04 PM   #4
Member
 
Join Date: Jan 2015
Location: Early
Posts: 47
I bought my 323LKTS in March. The Black tank flush was also mislabeled. Not a tragedy, but still an annoyance.
__________________
2015 Eagle 323 LKTS
2003 Ford F250 7.3 L Diesel
LegalEagle is offline   Reply With Quote
Old 06-23-2015, 07:49 AM   #5
Junior Member
 
Join Date: Jun 2015
Location: Jackson
Posts: 4
Quote:
Originally Posted by LegalEagle View Post
I bought my 323LKTS in March. The Black tank flush was also mislabeled. Not a tragedy, but still an annoyance.
We bought ours the beginning of April. I agree! Glad it's nothing major, but definitely annoying!
jjmauer is offline   Reply With Quote
Old 08-06-2015, 06:00 AM   #6
Junior Member
 
Join Date: Aug 2014
Location: Danbury, CT.
Posts: 22
Jjmauer,
We picked up our 325bhqs in April, while preparing for our trip to Disney in a week we found that the Black tank seems to also be mis labeled. I was wondering how yours runs, our goes Black, Grey and Grey. It looked like it is supposed to be Grey, Grey and then Black. On a side note did yours come with the reading lights over the queen bed, our were missing. I had Jayco send me the lights and wire so I could hook them up myself. Other wise we love the unit.
Engoff22 is offline   Reply With Quote
Old 08-06-2015, 06:51 AM   #7
Senior Member
 
Join Date: Jan 2011
Location: Vienna
Posts: 1,645
Lessons learned. The first trip out I always check the labels when I drain. Never had any labeled wrong yet, but you never know. Then all the switches that aren't labeled, I figure out what they are for and then put labels on them. Lots of stuff and switches not labeled that should be. Once you have been camping for awhile, you learn a lot of tricks about figuring this stuff out! Never too old to learn either. That's why I do a lot of "lurking" on this website. A wealth of information on here and most of it is pretty accurate!
__________________

Joe Hinson
2010 Jayco Quest G2(SOLD)
2014 Jayco Eagle 33.5RETS
2007 Ram 2500 5.9L Cummins(SOLD)
2015 Ram 2500 6.7L Cummins 4WD
:)
namusmc65 is offline   Reply With Quote
Old 08-06-2015, 03:16 PM   #8
Member
 
Join Date: Apr 2015
Location: Chandler
Posts: 71
Given the build "quality" of today's RVs, who says they're mislabeled and not misplumbed? :-(

Lyle
LAKnox is offline   Reply With Quote
Old 08-06-2015, 09:12 PM   #9
Junior Member
 
Join Date: Jun 2015
Location: Jackson
Posts: 4
Quote:
Originally Posted by Engoff22 View Post
Jjmauer,
We picked up our 325bhqs in April, while preparing for our trip to Disney in a week we found that the Black tank seems to also be mis labeled. I was wondering how yours runs, our goes Black, Grey and Grey. It looked like it is supposed to be Grey, Grey and then Black. On a side note did yours come with the reading lights over the queen bed, our were missing. I had Jayco send me the lights and wire so I could hook them up myself. Other wise we love the unit.
Interesting! Ours didn't come with lights over the bed either! I was just telling my husband that I thought that was weird. Were they easy to hook up? And that's exactly how our tanks were labelled, and they ended up being grey, grey, black also. So did you get new labels or just leave it that way?
jjmauer is offline   Reply With Quote
Old 08-07-2015, 04:55 AM   #10
Junior Member
 
Join Date: Aug 2014
Location: Danbury, CT.
Posts: 22
The lights were alittle PITA but not to bad. You have to use power from the USB ports on right side of bed. They sent me everything wire, screws, connectors and the lights. It also leaves you room to place them were you want on the headboard. I will be making a new label for the tanks. I'm not sure if this is why but, I was told by a Jayco supervisor who personally called me about the lights that this model was sent to another section of there plant that usually does HT models and the queen beds face the same in those models front to back so they had about 20 units slip by without the lights. Maybe that's why the tanks are missed labeled. I would check with your dealer to have them call Jayco for your lights. Good luck.
__________________

Engoff22 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.