Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 12-27-2010, 03:04 PM   #1
Junior Member
 
Join Date: Aug 2010
Location: NE Florida
Posts: 7
Looking for a good PDI Checklist and other thoughts regarding inspection

I'll be picking up our new Eagle 351 RLTS 5ver day after tomorrow and i'm looking for a good PDI checklist. Also if anyone has any other thoughts comments regarding things I should be checking please let me know.

Tks
Carlie
__________________

__________________
2011 Jayco Eagle 351 RLTS
clvickers is offline   Reply With Quote
Old 12-27-2010, 03:31 PM   #2
Senior Member
 
OurJayco's Avatar
 
Join Date: Nov 2009
Location: East Bethel, Minnesota
Posts: 659
Welcome to the Forum and good luck with your new Eagle!!
Here is a link to a checklist that is pretty thorough.
http://www.rvforum.net/joomla/index....layout=default

Hope this helps!!!
__________________

__________________
HAPPY CAMPING!! :D

Daryl and Sandy
2013 Eagle 314BDS
2012 Ford F150 Platinum, 4 x 4 Crew Cab with Ecoboost
Equal-i-zer Hitch
OurJayco is offline   Reply With Quote
Old 12-27-2010, 06:12 PM   #3
Site Team
 
Denise's Avatar
 
Join Date: Jul 2009
Location: Mostly the US
Posts: 10,004
Welcome to the Jayco Owners Forum Carlie! Daryl suggested a link that we actually used back when we picked up our tt in Sept 2009. Good luck. Let us know how you like your new Jayco!
__________________
moderator
Denise, DH, grandkids, and two rescue pups
-2016 Jay Flight 29QBS Elite
-2016 Ford F-250 XLT 4x2, 6.2L EFI V8, 4.30 Elec Lock, Heavy duty Alt
Denise is offline   Reply With Quote
Old 12-27-2010, 06:18 PM   #4
Senior Member
 
Join Date: Dec 2010
Posts: 427
I wish I would of learned that before I went shopping for mine... But I got lucky and found a wonderful Jayco Eagle with little to nothing wrong with it...

Oh Yeah Welcome to the site...
Mopar1973Man is offline   Reply With Quote
Old 12-28-2010, 07:15 AM   #5
Senior Member
 
Join Date: Nov 2010
Location: Jeffersonville, IN
Posts: 136
Welcome Carlie.
__________________
Wes Simkins
Masters Certified 2010-2011
Jayco Parts & Warranty
http://parts.cunninghamcampers.com
Jayco Parts Specialists Since 1973
I Got My Good Sam Membership For $19.00
cciparts is offline   Reply With Quote
Old 01-02-2011, 12:21 PM   #6
Junior Member
 
Join Date: Aug 2010
Location: NE Florida
Posts: 7
I really appreciate everyone's replies.

We didn't pickup the camper on Tuesday, the 28th, as planned. It was going to be in the 20's and I didn't feel like trying to do a PDI in freezing weather so I called and put it off till the next day when I knew the weather would be better. Got to Ocean Grove RV in St. Augustine Wednesday and allowed them to take me through "Their PDI" to begin with. In doing so, I did notice where some caulking needed some touch-up. When the tech was showing us the light switches it appeared that one of the security lights over the electrical hookup wasn't working and they couldn't, at the time figure out what was going on so we left the camper and came home until they could find the problem. Before we left I also had them order two MAXAIR II vent covers to install over the two vents. They were expected to arrive and be installed on Friday. On Thrusday afternoon Ocean Grove called and said they had resolved the issue regarding the outside light over the Electrical Hookup. I told them we'd be there friday.

Friday morning Ma and I left to get the camper. Once I arrived I spoke with the tech and found out that the only problem with the light had been misinformation. As it turned out, the switch that the tech thought should be activating the light in back was wrong. Oh Well..

At that point I started doing MY PDI since I had let them do theirs on Wednesday. Right off the bat things started going south. The camper has a remote unit that works with all three slides, the awning, the rear stabilizer jacks, and the front jacks. Well the remote will not work consistently. You can hear it trying to deploy the slide(s) but they don't move. You can get things to work sometimes by turning the remote units in the storage area off and back on sometimes. Everything works find if you are using the switches in the camper. Just a remote issue. I will say that on Wednesday the remote unit did work for the most part from what I saW so I don't know what's going on here. Jayco was closed for New years so we'll have to wait and see.

Another issue that I found was on what I call the "Cathedral Window". The seal between the window frame and the window glass on the bottom middle goes down behind frame so water would, in my opinion collect and eventually start to leak there. They are submitting this to Jayco for replacement but have sealed it with caulk for now.

The Screen Door has to be adjusted as it will not lock in place. Tried it by itself and with it connected to the door. This is a minor adjustment for sure.

In the kitchen, I found that the left side on one of the top drawers is rubbing against a screw head because the screw wasn't installed flat.

My wife spotted that the lining on the bottom of the couch needs to be folded back under and tacked/stapled. We told them not to cut the material cause it would probably start to fray apart.

I found that a piece of trim between the wall/ceiling in the bathroom is a little loose and needs to be stapled better.

The last issue that I noticed was that with the living room slides (2 of them) pulled in, I can see light in the corner on the floor. Looks like a opening of about 1 x 1 or bigger on both slides. Told them they need to check both ends of both slides and close up the openings as I'm sure that mice and other critters will find them faster than you can shake a stick.

UPS also didn't deliver the MAXAIR II Vents so they also still need to be received and installed.

Guess we wait and see how things go from here.
__________________
2011 Jayco Eagle 351 RLTS
clvickers is offline   Reply With Quote
Old 01-02-2011, 06:04 PM   #7
Site Team
 
Denise's Avatar
 
Join Date: Jul 2009
Location: Mostly the US
Posts: 10,004
Holy Cow! That's some list! Hope it's all finished for you and nothing else turns up!
__________________
moderator
Denise, DH, grandkids, and two rescue pups
-2016 Jay Flight 29QBS Elite
-2016 Ford F-250 XLT 4x2, 6.2L EFI V8, 4.30 Elec Lock, Heavy duty Alt
Denise is offline   Reply With Quote
Old 01-18-2011, 11:23 PM   #8
Junior Member
 
Join Date: Aug 2010
Location: NE Florida
Posts: 7
Unhappy Still no 5ver at the house

Well, its the 18th, I still don't have my 5ver and the only word we've heard so far from the dealer is that:

A) They received and installed the MAXAIR II vent covers

B) They have received the Key Blanks that I had requested for the spare keys but I will have to have them made somewhere else because I don't think they have the ability to cut keys there.

C) They looked for the openings where I was able to see light coming in at the bottom corner of the slides (when they were retracted) and they couldn't see any light.

D) Jayco wants them to run some test on the remote receivers so see if they are the problem.

I have heard nothing else so far on the cathedral window issue or the rest of the items I have listed above.

Guess I'll be calling them for info tomorrow. Sure am glad I bought new
__________________
2011 Jayco Eagle 351 RLTS
clvickers is offline   Reply With Quote
Old 07-28-2015, 05:52 PM   #9
Member
 
Join Date: May 2015
Location: SEMO
Posts: 54
Quote:
Originally Posted by clvickers View Post
The camper has a remote unit that works with all three slides, the awning, the rear stabilizer jacks, and the front jacks. Well the remote will not work consistently. You can hear it trying to deploy the slide(s) but they don't move. You can get things to work sometimes by turning the remote units in the storage area off and back on sometimes. Everything works find if you are using the switches in the camper. Just a remote issue. I will say that on Wednesday the remote unit did work for the most part from what I saW so I don't know what's going on here.

We are having the same issue with our touch screen remote on our new 2016 Eagle, and am wondering what you decided was causing the problem? I can also see light when our kitchen slide is retracted on 1 side and am wondering what you did to remedy that problem as well.
Lessmore is offline   Reply With Quote
Old 07-30-2015, 04:57 PM   #10
Senior Member
 
MikeNChelle's Avatar
 
Join Date: Jul 2012
Location: Chicagoland
Posts: 607
Quote:
Originally Posted by Lessmore View Post
We are having the same issue with our touch screen remote on our new 2016 Eagle, and am wondering what you decided was causing the problem? I can also see light when our kitchen slide is retracted on 1 side and am wondering what you did to remedy that problem as well.
Two totally different remotes I think. Our Eagle 351 RLTS had a big push button remote that NEVER worked. The receiver for it was in the basement behind the wall and there just wasn't enough power to make the remote link with the camper.
Our 2016 Pinnacle has a digital remote and really does work all of the functions listed.
__________________

__________________

2016 Pinnacle 36REQS
2014 Ford F-350 6.7 4x4 CC LB Dually
Mike & Chelle, My kids when they decide to go with us.
MikeNChelle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.