Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-07-2024, 11:16 PM   #1
Junior Member
 
Join Date: Mar 2024
Location: MUSKEGON
Posts: 3
Water pump wiring

I have a 2004 jayco eagle 285 . Every time I turn on the water pump I blow a fuse.i know there is a short in the wire to the pump. But for the life of me I don't know how to access the the camper wiring to replace the wire. Are there access panels that I'm not seeing? The whole bottom of the outside of the camper is enclosed. I have seen a what to open it up. Anybody have any ideas or know how to get to the wires. Any help is greatly appreciated

TIA
Lfalkowski is offline   Reply With Quote
Old 03-08-2024, 05:51 AM   #2
Senior Member
 
Join Date: Dec 2020
Location: South Brunswick
Posts: 342
This doesn't sound like a short in the wiring, it sounds more like a problem with the water pump. I would disconnect the positive wire from the pump and them try turning on the switch. If the fuse doesn't blow then you probably have a bad/stuck water pump. If it still blows then you have a short in the wiring between the switch and the pump.

Sorry, can't help you with accessing the underside wiring.
__________________

2015 Starcraft AR-ONE Maxx 21FB
2023 Chevrolet Suburban LT 1500
mrmom is offline   Reply With Quote
Old 03-08-2024, 05:54 PM   #3
Junior Member
 
Join Date: Mar 2024
Location: MUSKEGON
Posts: 3
It does the same with a new pump also.
I checked the continuity on the wires there is a short
I ran a new wire from the switch across the floor to the pump and it works fine.
Lfalkowski is offline   Reply With Quote
Old 03-08-2024, 06:16 PM   #4
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 16,484
Quote:
Originally Posted by Lfalkowski View Post
It does the same with a new pump also.
I checked the continuity on the wires there is a short
I ran a new wire from the switch across the floor to the pump and it works fine.
Does your rig have several switches to run the pump? If they are lighted, one could be bad and shorted out internally.
__________________
DISNEY LOVERS
Grumpy is offline   Reply With Quote
Old 03-23-2024, 11:16 AM   #5
Junior Member
 
Join Date: Mar 2024
Location: MUSKEGON
Posts: 3
I checked the switch panel everything looks to be working well.. I checked and rechecked that the problem is between the switch and the pump
Lfalkowski is offline   Reply With Quote
Reply

Tags
water pump, wiring, wiring help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.