Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-23-2023, 03:33 PM   #1
Member
 
Join Date: Sep 2023
Location: SAN DIEGO
Posts: 41
Jayco Terrain TSB 23-120

Anyone got this TSB and applied the new settings to the Renogy inverter/charger?
Among other settings they changed the #09 - Boost charge voltage from 54.4V to 53.6V. With the new settings battery does not charge more than 70%. Manual for the battery calls for 54.7V as charge voltage. So I don't understand how 53.6V going to completely charge the battery.
sid14184 is offline   Reply With Quote
Old 11-23-2023, 10:22 PM   #2
Senior Member
 
Join Date: Nov 2022
Location: State of Love and Trust
Posts: 139
Quote:
Originally Posted by sid14184 View Post
Anyone got this TSB and applied the new settings to the Renogy inverter/charger?
Among other settings they changed the #09 - Boost charge voltage from 54.4V to 53.6V. With the new settings battery does not charge more than 70%. Manual for the battery calls for 54.7V as charge voltage. So I don't understand how 53.6V going to completely charge the battery.
I didn't get the TSB but I did take it in because the van went crazy last Monday and they did the TSB which fixed everything.
RearViewMirror is offline   Reply With Quote
Old 12-12-2023, 10:58 AM   #3
WPW
Member
 
Join Date: Oct 2022
Location: Watauga
Posts: 42
I'm so sorry for not seeing this earlier, but yes, I got this too. I also have notice with that setting of 53.6 my battery doesn't fully charge. I actually called Dehco or whatever they're called now (the company has been renamed) on something else. The tech ask me randomly if Ive had this issue too, with it not complete charging. I said yes, but I told him that I change the inverter setting back to 54.0. He said that should still work ok. The 54.4 or 54.8 may lead to an over volt fault so they keep lowering it to avoid the fault. Speaking from experience plug into through shore power, if I had 54.8 to 54.4, I would get the over volt fault, only 54.0 do I not get the fault and my BMS screen shows 100% SOC.
WPW is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.