Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-06-2015, 10:44 PM   #1
Junior Member
 
Join Date: Aug 2014
Location: Mobile
Posts: 25
12V Interstate Deep Cycle Battery shows 16.9 Volts

I had my trailer hooked up to shore power for a couple days and now unplugged it. 4 hours later my DC plug in the trailer shows 12.75v. My 2 interstate batteries showed 16.2 after unhooking and 16.9 volts 2 hours later! Typically they are closer to 14.
Now I am about 4 hours after unhooking it and the batteries are at 16.9/17.1 Volts.

Batteries are same age Interstate SRM-24
What could be causing that to read so high? I have multimeter set to 20v DC.


Could low water levels cause that? trailer is 6 months old how often do you check the water. Is it "explosive" to pop the cap to check water level right after charge with reading that high?
__________________

__________________
2015 Jayco x19H
2012 Ram 1500 4.7
Smart Power 2000iQ
Barnaclepete is offline   Reply With Quote
Old 05-06-2015, 11:49 PM   #2
Junior Member
 
Join Date: Aug 2014
Location: Mobile
Posts: 25
Ok, disregard. Evidently there is a 9v battery on my 13 year old multi meter that had never been changed. Once I did that, batteries read 12.71 at batteries on multi meter.


Now back to my investigation of solar...
__________________
2015 Jayco x19H
2012 Ram 1500 4.7
Smart Power 2000iQ
Barnaclepete is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.