Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-06-2016, 02:29 PM   #1
Member
 
Join Date: Aug 2012
Posts: 77
Battery Dis-connect trouble

Having trouble getting the battery disconnect to cut power.
Installed on the neg post of one battery with a jumper going to the other battery neg post . First post has trailer ground and jumper on neg post. All the rest of the trailer wires are on the pos posts of both batteries.
when the disconnect is open I have power and closed I have power.
Very confused. Confirmed with an amp meter the disconnect is working properly.
scratching my bald head
Does anyone have the answer??
__________________

tshirtman is offline   Reply With Quote
Old 04-06-2016, 02:35 PM   #2
Senior Member
 
dalebra's Avatar
 
Join Date: Jun 2013
Location: Waconia, MN
Posts: 433
Quote:
Originally Posted by tshirtman View Post
Having trouble getting the battery disconnect to cut power.
Installed on the neg post of one battery with a jumper going to the other battery neg post . First post has trailer ground and jumper on neg post. All the rest of the trailer wires are on the pos posts of both batteries.
when the disconnect is open I have power and closed I have power.
Very confused. Confirmed with an amp meter the disconnect is working properly.
scratching my bald head
Does anyone have the answer??
I suspect it may be where you have the jumper from one NEG post to the other. It sounds like your disconnect is just disconnecting one battery instead of both. Yes?
__________________

__________________
2015 Chevy Silverado 2500HD CC Duramax
2016 Eagle 323LKTS Java
Pull Rite SuperGlide #4100 Hitch w/Mor-Ryde Pin Box
dalebra is offline   Reply With Quote
Old 04-06-2016, 03:00 PM   #3
Member
 
Swampy's Avatar
 
Join Date: Dec 2015
Location: Pearl River
Posts: 49
I think you need that connection to the trailer chasis behind your switch since you are trying to disconnect on the negative side.

Swampy
Swampy is offline   Reply With Quote
Old 04-06-2016, 03:27 PM   #4
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,030
I made the same mistake on mine years ago. Draw out what you actually have on a diagram and you will likely see that you are only removing one battery.
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 04-06-2016, 03:27 PM   #5
Senior Member
 
Join Date: Jun 2015
Location: smithville, ont.
Posts: 1,746
You are disconnecting the negative battery post from the chassis ground but your converter is still hooked up to the battery post ground?
What trailer?
__________________
2016 North Point 341RLTS
520watts of solar. Morningstar MPPT
2017 F-350 Platinum CC SRW
klassic is offline   Reply With Quote
Old 04-06-2016, 04:34 PM   #6
Senior Member
 
Mustang65's Avatar
 
Join Date: Nov 2012
Location: Clearwater, FL area
Posts: 3,671
It sounds like you installed the switch between the batteries. You need to relocate where you mounted the disconnect switch to a location between the batteries and the frame connection. There should be no other cables on the negative terminal
Don
Attached Images
 
__________________
2013 Jayco Eagle 284BHS
250Watt Grape Solar Panel, MorningStar MPPT 60 Charge Controller
1500 Watt Ramsond PSI, 2 Trojan T145 Batteries (260Ah)
2 - AirSight Wireless IP Cameras (used as rear view cameras)
EnGenius WI-FI extender, D-Link wireless (n) modem
MagicJack Internet Phone
2012 Ford F150XLT, EcoBoost w/3.73
157" Wheel base, HD Towing Package

Our Solar Album https://www.jaycoowners.com/album.php?albumid=329
Mustang65 is offline   Reply With Quote
Old 04-06-2016, 09:06 PM   #7
Senior Member
 
Join Date: Apr 2013
Location: Cleveland
Posts: 1,435
This might be a stupid question, but I am going to ask it anyway. When you were testing the battery disconnect, was your trailer disconnected from shore power and from the tow vehicle?
__________________
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote
Old 04-07-2016, 01:22 PM   #8
Member
 
Join Date: Aug 2012
Posts: 77
Smile Big thank You Jayco

Just an attaboy to the Jayco Twin Falls plant.
Needed a replacement Lippert Components leveler sticker for my 3013 Jay Flight . Lippert wanted $2.50 plus $10.00 to ship to me.
Jayco Twin Falls stepped up and sent 3 for FREE and even paid the stamp to mail.
Thanks Jayco for being an outstanding manufacturer and showing what customer service is all about
__________________

tshirtman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.