Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-28-2011, 05:47 AM   #11
Member
 
Join Date: May 2011
Location: North Jersey
Posts: 34
Keep us posted on what they found out on repair.I just picked up my 330rlts on 5/13/11 and used it for the first time and had a electric stabilizer motor broken,I hope to have no future issues with trailer.Good luck and let us know how it turns out.
__________________

novaplum is offline   Reply With Quote
Old 05-28-2011, 07:43 AM   #12
Senior Member
 
Join Date: Nov 2009
Location: Kentucky
Posts: 134
I have this problem with mine sometimes. I find it doesn't do it as bad when I run the water pressure low. Make sure your valves are open when you are flushing out the tank. I have not looked at where this is coming from, if you find it please post what you discovered.
__________________

__________________
2010 Jayco Eagle Super Lite 31.5 FBHS
08 Chevy 2500HD LTZ Duramax /CC/SB/4x4
glazier is offline   Reply With Quote
Old 05-28-2011, 10:30 PM   #13
Senior Member
 
Join Date: Nov 2009
Location: Orange County, N.Y.
Posts: 631
I had my black tank sprayer installer at the factory. Since this was the first time we had this option, I made sure to have the dealer show me how to use it during my PDI. While my main intention was to ensure I knew how to use this feature I am sure if the sprayer was not properly installed I would of seen the problem then.
__________________
Joe, Joyce , 4 Kids and 3 Dogs.
2004 V-10 Excursion with Hellwig sway bar, Roadmaster Active Suspension, Bilstein shocks and steering stabilizer, Super Duty Tow Mirrors,
3.73 Gears, Reese dual cam, Prodigy brake controller.
2010 Jayco Jay Flight G-2 32 BHDS
usmc616 is offline   Reply With Quote
Old 05-31-2011, 09:13 PM   #14
Moderator Emeritus
 
Rustic Eagle's Avatar
 
Join Date: Apr 2011
Location: Michigan
Posts: 7,370
Quote:
Originally Posted by bounder View Post
snip.......Everything went fine until I turned off the water to the sprayer, water poured out of the belly of my trailer. Anybody ever have this problem?.....snip
Yep, twice. The first time Jayco didn't have the unit tightened properly (factory install, 2004), the second time was last year the sprayer unit rusted around the mounting flange.

Bob

PS: While your dealer has the underbelly off, confirm that the sprayer water line is routed such that no water can collect and freeze during the winter months (I give mine a shot of air when I winterize mine).
__________________

2016 GM 2500HD 6.0L/4.10
2018 Jay Flight 24RBS
2005 Jayco Eagle 278FBS (retired)
1999 Jayco Eagle 246FB (retired)
Reese HP Dual Cam (integrated sway control)
Rustic Eagle is offline   Reply With Quote
Old 05-31-2011, 10:07 PM   #15
Senior Member
 
bounder's Avatar
 
Join Date: Jan 2011
Location: Calif.
Posts: 381
Thanks for all the feed back. I will keep everybody posted.
Ernie
__________________
Ernie
Cancer survivor, retired, living life to its fullest with my lovely wife Nancy and our dog Abbey.
2011 Eagle 330RLTS trailer
Reese straight line dual cam
17k wd hitch
2005 GMC diesel
Crew cab long bed
:Flag:
bounder is offline   Reply With Quote
Old 06-03-2011, 08:54 AM   #16
Junior Member
 
Join Date: Apr 2011
Location: E. Washington State
Posts: 12
Hello Bounder! sorry to hear about your spray issue. I had mine installed from the dealer and they told me to make sure I dont have my valve closed because the pressure from water could crack the tank. So did you have your black tank valve wide open?
Kbuck0524 is offline   Reply With Quote
Old 06-03-2011, 09:12 AM   #17
Senior Member
 
bounder's Avatar
 
Join Date: Jan 2011
Location: Calif.
Posts: 381
Yes I had the valve open.
__________________
Ernie
Cancer survivor, retired, living life to its fullest with my lovely wife Nancy and our dog Abbey.
2011 Eagle 330RLTS trailer
Reese straight line dual cam
17k wd hitch
2005 GMC diesel
Crew cab long bed
:Flag:
bounder is offline   Reply With Quote
Old 06-07-2011, 10:22 AM   #18
Senior Member
 
bounder's Avatar
 
Join Date: Jan 2011
Location: Calif.
Posts: 381
Jayco dealer called today. The black tank sprayer had a loose connection & the insulation was soaked. Dealer tightned the fitting & replaced the wet insulation.
__________________
Ernie
Cancer survivor, retired, living life to its fullest with my lovely wife Nancy and our dog Abbey.
2011 Eagle 330RLTS trailer
Reese straight line dual cam
17k wd hitch
2005 GMC diesel
Crew cab long bed
:Flag:
bounder is offline   Reply With Quote
Old 06-09-2011, 12:25 AM   #19
Senior Member
 
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,303
Quote:
Originally Posted by bounder View Post
It was installed at the factory. Makes me wonder about Jayco's quality control. The factory must not pressure test the lines.
The dealer is supposed to check that before you do a PDC. They should check the propane appliances, electrical systems, and water for leaks.
clutch is offline   Reply With Quote
Old 06-09-2011, 01:18 PM   #20
Senior Member
 
bounder's Avatar
 
Join Date: Jan 2011
Location: Calif.
Posts: 381
Just hooked up the water to the black tank sprayer. Guess what it leaks just like before. The dealer assured me it was fixed & the tech tested it.
__________________

__________________
Ernie
Cancer survivor, retired, living life to its fullest with my lovely wife Nancy and our dog Abbey.
2011 Eagle 330RLTS trailer
Reese straight line dual cam
17k wd hitch
2005 GMC diesel
Crew cab long bed
:Flag:
bounder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 05:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.