Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-20-2017, 12:16 PM   #1
Junior Member
 
Join Date: Aug 2017
Location: Peoria
Posts: 13
First the radio now the furnace...

Well atleast this is our last trip for the year but before going to bed last night I tried to start the furnace. Switched the thermostat on and cranked the heat...nothing...havent dug into it much as to what the issue is yet but I guess I'll have some work for the dealership when I get back next week. If we end up having time this weekend I may start troubleshooting the issue. If I find anything I'll porlst the update.
__________________

Chevy79bu is offline   Reply With Quote
Old 10-20-2017, 12:55 PM   #2
Member
 
Join Date: Jul 2017
Location: Grand Rapids
Posts: 72
Is the gas on? (check to see if the stove burners light)

Those furnaces are pretty simple systems, if you have gas and electricity (for the blower) then you should have heat.
__________________

__________________
2015 Eagle HT 28.5 RSTS
2011 Silverado 2500HD 6.0 Gas
DavidJay is offline   Reply With Quote
Old 10-20-2017, 12:58 PM   #3
Senior Member
 
oldmanAZ's Avatar
 
Join Date: Dec 2014
Location: AZ
Posts: 6,884
So please let us know what you find and if 'nothing' means the fan didn't start running or the burner didn't fire or ???
__________________
Sherm & Terry w/rescues Eydie (min Schnauzer) Steve RIP (std Poodle)
2015 Jay Flight 27RLS (Camped: 102 nights '15, 90 nights '16, 70 nights '17 so far)
2006 Ford F350 6.0 PSD, Lariat, 4WD, CC, LB, SRW, auto., Camper pkg.
oldmanAZ is online now   Reply With Quote
Old 10-20-2017, 08:34 PM   #4
Junior Member
 
Join Date: Aug 2017
Location: Peoria
Posts: 13
I agree the systems are simple. I am a factory mechanic for industrial heat treat equipment by trade lol. Yes there is gas going to the furnace and I was able to mess with it some and there is no power going to the thermostat. We are plugged into power at the camp site and everything else is getting power so I'm not sure where the issue is. Other than when I first got the trailer home and was going through everything 2 months ago I have not started the furnace. At this point with the stereo going out and the furnace I'm not going to do any more troubleshooting. I considered ringing out the wiring for the thermostat but with it being under warrantee then I'll just take it back to the dealership next week. It was cold in the camper last night but only my wife and I are on this trip so without having the kids in not that worried. Besides being cold me and she has to snuggle up to me a little closer...not a bad thing.
Chevy79bu is offline   Reply With Quote
Old 10-20-2017, 08:55 PM   #5
Senior Member
 
Join Date: May 2017
Location: Connellsville
Posts: 1,557
Quote:
Originally Posted by Chevy79bu View Post
Besides being cold me and she has to snuggle up to me a little closer...not a bad thing.
If I were in your shoes and had the choice between fixing the heater and snuggling with the wife........I'd fix the heat.
Midnightmoon is offline   Reply With Quote
Old 10-20-2017, 09:10 PM   #6
Junior Member
 
Join Date: Aug 2017
Location: Peoria
Posts: 13
Lol well sorry to hear that but as for myself I'll take the wife any day of the week.
Chevy79bu is offline   Reply With Quote
Old 10-20-2017, 09:21 PM   #7
Senior Member
 
Join Date: May 2017
Location: Connellsville
Posts: 1,557
Quote:
Originally Posted by Chevy79bu View Post
Lol well sorry to hear that but as for myself I'll take the wife any day of the week.
In fact, my wife just read your thread with me and suggested that I get up and turn the thermostat up.
__________________
2017 Jay Feather 7 22BHM Baja
2007 Ram 2500 Cummins 4x4
Anderson WD

Midnightmoon is offline   Reply With Quote
Old 10-21-2017, 02:50 AM   #8
Senior Member
 
wags999's Avatar
 
Join Date: Jan 2015
Location: Surprise
Posts: 1,483
Both those systems work on 12volts..... also depending on what furnace you have there is a reset switch on the top, may try that see if it helps.. The boards in the furnaces are easily damaged with power irregularities.

Good Luck...
__________________
2011 Toyota Tundra double cab
2015 27RLS
wags999 is offline   Reply With Quote
Old 10-21-2017, 06:50 AM   #9
Senior Member
 
Marcm157's Avatar
 
Join Date: Jun 2016
Location: Newburgh
Posts: 2,221
Quote:
Originally Posted by Midnightmoon View Post
If I were in your shoes and had the choice between fixing the heater and snuggling with the wife........I'd fix the heat.
I'm with you! you've obviously been married a long time!!!
__________________
_______________________________________________
2016 Ford F250 Supercab - 6.2 - Equalizer 12K WD Hitch
2016 Ford F150 Scab - 3.5 Ecoboost HD Tow - Roadmaster Active Suspension - (Reluctantly sold and deeply missed)
2016 Jayco 28BHBE - Progressive Industries EMS-HW30C
Marcm157 is offline   Reply With Quote
Old 10-21-2017, 08:49 AM   #10
Senior Member
 
tkhollywood's Avatar
 
Join Date: Jun 2014
Location: sterling heights
Posts: 143
Same thing happened to me last year. Ran to the store and bought a small electric heater used it for the weekend then returned it. Turned out it was a loose wire that connects to the circuit board on the heater.
__________________

__________________
2014 white hawk 33bhbs
tkhollywood is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.