Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-27-2017, 02:55 AM   #1
Junior Member
 
Join Date: Jun 2017
Location: Santa clarita
Posts: 1
I'm a newbie and can't figure out fresh water fill

So I have been trying to fill my fresh water tank for hours now. Water keeps coming from overflow if I turn it up too much but the problem is.... it's only registering my tank at 1/3 and I've been filling it with water forever already with several spill outs. What am I doing wrong? How long does it usually take to fill 48 gallons?
I have a jayco 2017 x213
__________________

Welshdamsel is offline   Reply With Quote
Old 06-27-2017, 03:59 AM   #2
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,384
It is likely full. The tank level indicators are notoriously incorrect. However the fresh water is usually the only one that is pretty accurate.

Welcome to JOF.
__________________

__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 06-28-2017, 10:10 PM   #3
Member
 
Join Date: May 2016
Location: Parma
Posts: 51
Check underneath, it's not uncommon for one of the wires to be disconnected from the sensors or the ground wire isn't screwed to the frame.


Sent from my iPhone using Tapatalk
DamonZ8 is offline   Reply With Quote
Old 06-29-2017, 08:12 AM   #4
Senior Member
 
Cranetech's Avatar
 
Join Date: Apr 2017
Location: Port coquitlam
Posts: 142
May take a bit but would be good for your sanity. Can you drain into a 5 gal pail and see how much water comes out? Would verify if sensor is correct or not.
Cranetech is offline   Reply With Quote
Old 06-29-2017, 08:39 AM   #5
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,239
Hello welcome aboard! Did you resolve your issue? I too suspect that your sensors are not reading correctly. Do you have an open underbelly (aka can you see the tanks, or is there a heavy plastic covering. If you can see the tanks there are a several wires connected to the sensors. These wires have a tendency to have a lot of slack and can be snagged by road debris. When our HTT was new, I applied liquid electrical tape to the physical connections to keep corrosion at bay. Then I used a couple zip ties to pull the wires up so that road debris cannot snag the wires.

The wire harness then routes back to the control panel. A wire(s) might not be connect at the control panel. Worse case scenario a staple damaged the wire harness. If your TT is brand new, it will be covered by warranty, but you have to haul it here and it will sit on their lot for a couple weeks. It maybe worth looking at it yourself.
Jagiven is offline   Reply With Quote
Old 06-29-2017, 10:40 AM   #6
Senior Member
 
RPreeb's Avatar
 
Join Date: Oct 2016
Location: NE Colorado
Posts: 311
Quote:
Originally Posted by Welshdamsel View Post
So I have been trying to fill my fresh water tank for hours now. Water keeps coming from overflow if I turn it up too much but the problem is.... it's only registering my tank at 1/3 and I've been filling it with water forever already with several spill outs. What am I doing wrong? How long does it usually take to fill 48 gallons?
I have a jayco 2017 x213
I have a 2017 X213 too and I had to install a ball valve on the overflow tube to shut it off or it will siphon most of the water back out of the tank once it starts to flow. Now as soon as the overflow begins to drain, I shut off the valve on the overflow tube and I have a full tank with which to travel and camp.

I don't know how they put the tube in the tank, but there must be a few inches of it inside the tank to act as a siphon, and the end outside of the tank does hang below the bottom of the tank... makes a great siphon, but not such a great overflow system. I have the enclosed underside, so I can't easily see what's going on in there or make any other modifications on it.
__________________
Rick



2016 F-150 XLT 4x4 Super Crew 3.5L Ecoboost
2017 Jay Feather X213
RPreeb is offline   Reply With Quote
Old 06-29-2017, 12:00 PM   #7
Junior Member
 
trailer virgin's Avatar
 
Join Date: Oct 2016
Location: Colorado
Posts: 10
You have to fill the fresh water tank s l o w l y... Water goes too fast, it won't fill correctly. I read this somewhere (probably on this forum) when I was having a problem.
__________________
2017 Flight SLX 245RLSW
2013 Toyota Tundra 5.7L V8
trailer virgin is offline   Reply With Quote
Old 06-29-2017, 12:39 PM   #8
Senior Member
 
RPreeb's Avatar
 
Join Date: Oct 2016
Location: NE Colorado
Posts: 311
Quote:
Originally Posted by trailer virgin View Post
You have to fill the fresh water tank s l o w l y... Water goes too fast, it won't fill correctly. I read this somewhere (probably on this forum) when I was having a problem.
Fir my X213, I could use an eyedropper and it wouldn't make any difference. We have very low water pressure here and I barely crack the spigot... doesn't change anything. The tank still siphons 3/4 of the water back out.
__________________
Rick



2016 F-150 XLT 4x4 Super Crew 3.5L Ecoboost
2017 Jay Feather X213
RPreeb is offline   Reply With Quote
Old 02-13-2018, 11:56 AM   #9
Junior Member
 
Join Date: Jan 2018
Location: Albuquerque
Posts: 27
Filler tube and connector

The filler tube for my freshwater tank on my 23 RL seems loose. Itís almost like it wants me to pull it up and away from the side of the trailer. Iím a bit leery of doing that for fear of pulling the hose apart inside the wall. Can someone please tell me why the filler tube seems to be loose?
Fyouberg is offline   Reply With Quote
Old 02-13-2018, 04:55 PM   #10
Senior Member
 
RPreeb's Avatar
 
Join Date: Oct 2016
Location: NE Colorado
Posts: 311
Quote:
Originally Posted by Fyouberg View Post
The filler tube for my freshwater tank on my 23 RL seems loose. Itís almost like it wants me to pull it up and away from the side of the trailer. Iím a bit leery of doing that for fear of pulling the hose apart inside the wall. Can someone please tell me why the filler tube seems to be loose?
Mine is the same. I push it in and about 1/4 turn clockwise and it should click back in place. Doesn't seem to be a problem.
__________________

__________________
Rick



2016 F-150 XLT 4x4 Super Crew 3.5L Ecoboost
2017 Jay Feather X213
RPreeb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.