Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-23-2014, 11:36 PM   #1
Junior Member
 
Join Date: May 2014
Location: Clinton
Posts: 19
Kitchen Water Pressure???

Does anyone have low water pressure at the kitchen sink and great pressure in bathroom and shower? I have taken it apart and there is nothing in the screens and water diffuser....any other ideas?
__________________

Cheddy is offline   Reply With Quote
Old 05-24-2014, 06:44 AM   #2
Senior Member
 
Tunce the traveler's Avatar
 
Join Date: Aug 2013
Location: Bellingham,Wa.
Posts: 4,627
Is it the same with the Hot as well as the Cold side? Knowing the year and model you have might help us.
__________________

Tunce the traveler is offline   Reply With Quote
Old 05-24-2014, 07:07 AM   #3
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,056
Did you try running the water w/o the diffuser for a few seconds in case there is an obstruction?
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 05-24-2014, 07:14 AM   #4
Junior Member
 
Join Date: Aug 2011
Posts: 12
I have lower pressure on the kitchen cold. The kitchen hot, and bathroom(h&c) are great. Only thing I can think is causing the lower pressure is the in-line water filter on the kitchen cold. Trailer is '09 32BHDS.
Webeskiing is offline   Reply With Quote
Old 05-24-2014, 08:26 AM   #5
Junior Member
 
Join Date: May 2014
Location: Clinton
Posts: 19
Reply

Yes, I have tried with and without diffuser. Same pressure on hot or cold or together. Bathroom and shower are both real good. The unit is a 2014 19RD, does it have a water filteration system that I'm not aware of? Thanks.
Cheddy is offline   Reply With Quote
Old 05-24-2014, 08:55 AM   #6
Junior Member
 
labracorn's Avatar
 
Join Date: Mar 2014
Location: Gravenhurst
Posts: 23
you may try to run your hand over the copper pipe from the fawcett under the sink they may have kinked the pipe when it was installed.
labracorn is offline   Reply With Quote
Old 05-24-2014, 09:47 AM   #7
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,056
Mine has a factory inline water filter under the sink. Easy to bypass with the provided hose.
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 05-24-2014, 07:10 PM   #8
Senior Member
 
Join Date: Apr 2013
Location: Cleveland
Posts: 1,435
x2 Norty1
__________________
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote
Old 05-24-2014, 09:23 PM   #9
Senior Member
 
Camping Couple's Avatar
 
Join Date: Aug 2012
Location: Kalamazoo
Posts: 726
Had this same thing happen to our kitchen faucet as well. It ended up being a plastic shaving of the pex tubing stuck in the tube. I only found it after I took the tubing off under the faucet. I just pushed it out with a straight piece of wire.
__________________

2015 Jayco 24FBS Elite Jay Flight
2013 Chevrolet Silverado 2500HD 4X4 6.0L 3.73 Axle
HD Trailering Package with Integrated Brake Controller
Equal-i-zer Hitch 10k/1000
Camping Couple is offline   Reply With Quote
Old 05-24-2014, 11:48 PM   #10
Junior Member
 
Join Date: May 2014
Location: Clinton
Posts: 19
Can't see a water filter, but I'll take a better look once Home. Line is not pinched. I'll check for something in the line....if not that, then off to dealer for the warranty work. Thx for the replies. Also, something random on the first trip out I noticed two speakers above master bed were not working, they were wired, but never wired to the actually radio; figured it out after removing the radio. Overall quality for the most part seems very good, but time to get the 16 yr. olds out of the Jayco factory.
__________________

Cheddy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.