Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 10-18-2011, 09:21 AM   #21
Member
 
Join Date: Aug 2011
Location: Mobile, AL
Posts: 77
Quote:
Originally Posted by tafische View Post
Took mine off today while I was sitting around the camp site. To make a ground point, the dealer put a washer under one of the bolts, but they did not clean the paint away. A little rust formed and it no longer had a good connection. Cleaned it all up and it seems to be working great.

A few comments from the other posts -- my light was working until I put the jack under load then it stopped


I have no problem with the way they are grounding, since I am grounding through a bolt that then goes through the frame so it is an excellent ground point. The problem I have is they don't seem to have a good ground connection on the frame of the jack out of the box. If you take a little paint off under the bolts, it should do quite well. Time will tell.
I put two of the supplied washers under the front bolt to insure a good connection after using a very stiff wire brush to remove the paint and expose the metal. Connection seems very solid.

John
__________________

__________________

2004 GMC Sierra 1500 Ext Cab Z71
2007 Jayco Jay Flight 26BHS
NewToMeJF26BHS is offline   Reply With Quote
Old 10-19-2011, 08:05 PM   #22
Junior Member
 
Join Date: Jul 2011
Location: South Jersey
Posts: 25
Quote:
Originally Posted by NewToMeJF26BHS View Post
Try reconnecting the double black wire connector to the terminal next to the orange wire and it should work. Sorry it took me so long to pop mine back off and look at it again.

John
Thanks for checking the wires. I called Barker directly as instructed by the place where it was purchased. They did not even try to troubleshoot the problem. They think it's a defective motor head and are sending me a new one with a postage paid return for the broken one.
I may still try to plug the clip in and see what happens.

The light stays on regardless of trying the motor. In our own trouble shooting, we wire brushed the frame to shiny metal and put those washers on all three bolts. However, we did not wire brush the bottom of the plate on the jack. Shouldn't need to...shouldn't it come from factory ready to ground?????
__________________

__________________
2003 Jayco Eagle266
2008 Dodge Ram Laramie Hemi quad cab
Equalizer hitch
1 husband
1 stepdaughter 26 yrs old
1 Mastiff mix 4yrs old
rayvan is offline   Reply With Quote
Old 10-19-2011, 09:40 PM   #23
Senior Member
 
Terry's Avatar
 
Join Date: Feb 2011
Location: Germantown, TN
Posts: 4,923
Quote:
Originally Posted by rayvan View Post
Thanks for checking the wires. I called Barker directly as instructed by the place where it was purchased. They did not even try to troubleshoot the problem. They think it's a defective motor head and are sending me a new one with a postage paid return for the broken one.
I may still try to plug the clip in and see what happens.

The light stays on regardless of trying the motor. In our own trouble shooting, we wire brushed the frame to shiny metal and put those washers on all three bolts. However, we did not wire brush the bottom of the plate on the jack. Shouldn't need to...shouldn't it come from factory ready to ground?????
Glad Barker is taking care of you. I have both a jack and a blue tank from them. I have always heard they were good to work with.

The jack is one of the few accessories I did not install myself since it was part of the deal with I purchased my camper. I dug out the manual and it does say to use the tooth washer and scrape off the paint - which my installer did not do a great job on.

My thought is this this is a typical maintenance item - once a year when you lube the head (per the instructions) that you should also remove the three bolts and clean your ground point. Mine lasted two years, but probably good to do every year for good measure.
__________________
Terry
2009 Jayco 26BH
2004 Chevy Silverado 1500
2009 JayFlight Manual Library

Want to add a signature to your posts? --> Click Here
Terry is offline   Reply With Quote
Old 10-20-2011, 08:29 AM   #24
Junior Member
 
Join Date: Jul 2011
Location: South Jersey
Posts: 25
Good advice. I hope I get longer than 2yrs I kept thinking we should have let the dealer purity on, but I guess that's not always true...
__________________
2003 Jayco Eagle266
2008 Dodge Ram Laramie Hemi quad cab
Equalizer hitch
1 husband
1 stepdaughter 26 yrs old
1 Mastiff mix 4yrs old
rayvan is offline   Reply With Quote
Old 10-20-2011, 10:19 AM   #25
Member
 
Join Date: Aug 2011
Location: Mobile, AL
Posts: 77
Quote:
Originally Posted by rayvan View Post
Thanks for checking the wires. I called Barker directly as instructed by the place where it was purchased. They did not even try to troubleshoot the problem. They think it's a defective motor head and are sending me a new one with a postage paid return for the broken one.
I may still try to plug the clip in and see what happens.

The light stays on regardless of trying the motor. In our own trouble shooting, we wire brushed the frame to shiny metal and put those washers on all three bolts. However, we did not wire brush the bottom of the plate on the jack. Shouldn't need to...shouldn't it come from factory ready to ground?????
I can't remember if I had to wire brush the contact point on the jack or not, but it would be a good idea though. I used two of the supplied washers on the single bolt for the grounding contact to make sure I had a solid connection.

John
__________________

2004 GMC Sierra 1500 Ext Cab Z71
2007 Jayco Jay Flight 26BHS
NewToMeJF26BHS is offline   Reply With Quote
Old 10-22-2011, 07:19 PM   #26
Junior Member
 
Join Date: Jul 2011
Location: South Jersey
Posts: 25
The new power head arrived from Barker after 2days! We put it on and it worked like a charm! I've alway heard great things about their customer service and I am a true believer. They even sent me a cover that I did not even ask for!
__________________
2003 Jayco Eagle266
2008 Dodge Ram Laramie Hemi quad cab
Equalizer hitch
1 husband
1 stepdaughter 26 yrs old
1 Mastiff mix 4yrs old
rayvan is offline   Reply With Quote
Old 10-22-2011, 07:52 PM   #27
Site Team
 
Crabman's Avatar
 
Join Date: Nov 2010
Location: Virginia`s Eastern Shore
Posts: 14,654
I have heard good things about them (Barker) too. And surprise, surprise they are made in Michigan, not China like some other tongue jacks. I think Michigan can use our business more then China! I also have a Barker 3000 jack and a 22 gallon blue tote.
__________________
2017 Coachmen Catalina 283RKS
2004 Chevy 2500 HD CC 6.0l
2010 Jayflight 28BHS (sold)
Crabman is online now   Reply With Quote
Old 10-22-2011, 10:53 PM   #28
Senior Member
 
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,303
It is nice to hear about positive experiences. That is a name I will remember.
__________________
2011 Eagle 330RLTS with just about every option.
2017 Silverado 1500 4x4 5.3 with tow package.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote
Old 10-23-2011, 07:04 AM   #29
Moderator Emeritus
 
Rustic Eagle's Avatar
 
Join Date: Apr 2011
Location: Michigan
Posts: 7,370
Quote:
Originally Posted by Crabman View Post
snip......I think Michigan can use our business more then China!....snip
Lee,

More than you can imagine!

Bob
__________________

2016 GM 2500HD 6.0L/4.10
2018 Jay Flight 24RBS
2005 Jayco Eagle 278FBS (retired)
1999 Jayco Eagle 246FB (retired)
Reese HP Dual Cam (integrated sway control)
Rustic Eagle is offline   Reply With Quote
Old 10-23-2011, 10:00 PM   #30
Senior Member
 
Join Date: Nov 2009
Location: Orange County, N.Y.
Posts: 631
I have been following this post closely. We had a Barker 3500 installed last year and it has worked great, until yesterday. It lowered fine, but as it raised the TT it started to bog down and then quit. I checked all connections and then hand cranked it up. It started to work again and then stopped. It will lower fine just not raise, my installer thinks it may be the motor and will stop by this week to take a look at it.
__________________

__________________
Joe, Joyce , 4 Kids and 3 Dogs.
2004 V-10 Excursion with Hellwig sway bar, Roadmaster Active Suspension, Bilstein shocks and steering stabilizer, Super Duty Tow Mirrors,
3.73 Gears, Reese dual cam, Prodigy brake controller.
2010 Jayco Jay Flight G-2 32 BHDS
usmc616 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.