Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
Jayco RV Owners Forum
 


Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-12-2015, 06:48 PM   #1
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
no power from 7 way plug?

So I went to hookup new to me TV to trailer and had no lights.
I jumped #4 12v on plug to #3 taillights on plug and had nothing.
Checked fuse and connections, all good. Changed fuse anyway.

What am I missing?
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-12-2015, 06:54 PM   #2
Senior Member
 
Paintinfool3's Avatar
 
Join Date: Apr 2014
Location: Fort Wayne
Posts: 1,271
did you test the truck plug to a good ground and make sure it was good on the truck side ... then I would check the ground on the trailer ... no lights usually means no ground
__________________
2011 F250 King Ranch Crew Cab Diesel , 2015 Jayco Eagle 338 rets
Paintinfool3 is offline   Reply With Quote
Old 03-12-2015, 07:01 PM   #3
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
Ground is good from what I see
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-12-2015, 07:05 PM   #4
Senior Member
 
Paintinfool3's Avatar
 
Join Date: Apr 2014
Location: Fort Wayne
Posts: 1,271
well you would think it would carry through the hitch also but just a thought ... seems weird no lights , what about turn signals
__________________
2011 F250 King Ranch Crew Cab Diesel , 2015 Jayco Eagle 338 rets
Paintinfool3 is offline   Reply With Quote
Old 03-12-2015, 07:15 PM   #5
Senior Member
 
Join Date: May 2013
Location: Dale Hollow Lake Tn/Ky
Posts: 2,525
put a meter on the tv socket and make sure you are getting power at the bumper socket. If yes, and you've got nothing on the trailer, your problem is most likely a ground. Had this problem on my trip home from the gulf last week. Had to make an emergency stop at a very kind rv dealer who found the problem almost immediately. There should be a junction box under the tongue frame where the pigtail connects to the tt wiring. Looks just like a typical electric junction box because that is what it is. Remove the cover and inside will be a lot of wires where the power from the tv is connected to the trailer lites. Mine had plastic twist caps connecting wires to the tail lites, marker lites, etc. There most likely is a large bundle of white wires [not sure why there are so many] connected by one twist on cap. Too many wires in my mind to get a reliable connection for the ground. When the tech fiddled with the ground bundle the lites all popped on. He secured the grounds and connected one of them with a self tapping screw to the back of the junction box. Betting you'll find your problem in the same place.
Bassdogs is offline   Reply With Quote
Old 03-12-2015, 07:20 PM   #6
Member
 
Join Date: Nov 2012
Location: Central PA
Posts: 37
Often the fuse to the plug is not installed from the factory.
Tharrison is offline   Reply With Quote
Old 03-12-2015, 07:20 PM   #7
Senior Member
 
ninjahbob's Avatar
 
Join Date: May 2014
Location: Eatonton
Posts: 305
Bassdogs advice is right on. If not let us know.
ninjahbob is offline   Reply With Quote
Old 03-12-2015, 07:39 PM   #8
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
Quote:
Originally Posted by Paintinfool3 View Post
well you would think it would carry through the hitch also but just a thought ... seems weird no lights , what about turn signals
no turn signals either!
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-12-2015, 07:40 PM   #9
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
Quote:
Originally Posted by Tharrison View Post
Often the fuse to the plug is not installed from the factory.
Did I not ay that I replaced fuse?
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-12-2015, 07:44 PM   #10
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
Quote:
Originally Posted by Paintinfool3 View Post
well you would think it would carry through the hitch also but just a thought ... seems weird no lights , what about turn signals
Not concerned right now about TV just trailer plug which is hooked up to good battery
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-12-2015, 08:33 PM   #11
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
Problem seems to be between plug and trailer battery
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Old 03-13-2015, 04:15 AM   #12
Senior Member
 
Join Date: Aug 2013
Location: NC
Posts: 974
You will find the bad ground either in the box already mentioned or in some cases that bundle of grounds has a single pigtail that connects to the frame somwhere close to your ball on the A frame. Electrolysis always eats that type connection up.
__________________
No man has a good enough memory to be a successful liar. Abraham Lincoln

2016 36FBTS Pinnacle
2016 F350, 6.7, 4x4, DRW, long bed
B & W Companion 5th wheel Hitch
eldermike is offline   Reply With Quote
Old 03-13-2015, 05:46 AM   #13
Senior Member
 
RoyBraddy's Avatar
 
Join Date: Sep 2011
Location: King George
Posts: 2,761
I carry one of these 7-way Trailer adapter n RV TOOL BOX that takes the guessing out of what is at fault. The TRUCK SIDE or the TRAILER SIDE... Got mine from AMAZON...



When I got my 2010 FORD Truck it has an unmarked envelope in the glove box that had a 12VDC FUSE and RELAY. Finally figured out these were for the TRAILER TOW connector. The FUSE and RELAY had to be installed in the TRUCK FUSE panel The 12VDC would only be ON when the truck ignition key was ON. My truck also had individual fuses for the DOT Safety lights.

This did not however affect the DOT safety lights - Only the truck 12VDC charge voltage for the trailer battery.

Roy Ken
__________________
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA
RETIRED DOD DOAF DON CONTRACTOR Electronics Tech 42YRS

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 03-13-2015, 08:06 AM   #14
Senior Member
 
Join Date: May 2013
Location: Dale Hollow Lake Tn/Ky
Posts: 2,525
Quote:
Originally Posted by dennis b View Post
Not concerned right now about TV just trailer plug which is hooked up to good battery
If the TT is not on the ball, you do not have a ground. Hook the TT to the TV after confirming that you have power at the socket. Center post on the TV socket is the ground. Other ports are for tail lites, turn, marker lites and brakes. If no power thru the socket, you have a problem somewhere on the TV. If yes, see my previous post and check in the junction box.

Problem solving is a series of steps that isolate the problem. By learning what it is and what it isn't and by going step by step thru the system you will eventually find the fault.
Bassdogs is offline   Reply With Quote
Old 03-13-2015, 08:10 AM   #15
Senior Member
 
Join Date: May 2013
Location: Dale Hollow Lake Tn/Ky
Posts: 2,525
If the "good" battery you mention is the TT house battery, that battery has nothing to do with your TT nav lites. Why are you avoiding hooking up to the TV?
Bassdogs is offline   Reply With Quote
Old 03-13-2015, 08:56 AM   #16
Senior Member
 
Join Date: May 2013
Location: SE Wisconsin
Posts: 3,430
Quote:
Originally Posted by Bassdogs View Post
If the TT is not on the ball, you do not have a ground.
X2! I learned this the hard way many years ago when I had a pop-up. I was going through the same thing as the OP, when all I had to do was hook up like I was ready to travel, and guess what? Everything worked fine.
__________________
Chuck
2013 Jayco Jayfeather X20 E (sold)
2016 Chevy Silverado LTZ 2 Z71 Crew Cab (sold, and dearly missed)
DocBrown is offline   Reply With Quote
Old 03-13-2015, 08:58 AM   #17
Senior Member
 
Join Date: May 2013
Location: SE Wisconsin
Posts: 3,430
Here's a link to Roy's nifty tester!
__________________
Chuck
2013 Jayco Jayfeather X20 E (sold)
2016 Chevy Silverado LTZ 2 Z71 Crew Cab (sold, and dearly missed)
DocBrown is offline   Reply With Quote
Old 03-13-2015, 10:33 AM   #18
Senior Member
 
dennis b's Avatar
 
Join Date: Sep 2014
Location: Hartford
Posts: 2,619
PROBLEM FOUND!!!!!!!!!!!!!!!!!!!!!!!!!


Fuse socket not making good connection!


Thanks to all that responded! I gotta put Roy's tester on my want list.
__________________
2015 Fi50 3.5 Ecoboost w/tow max
2018 Flagstaff Super Lite 29RKWS
2011 Jayco 28BHS
2005 F150 Platinum/Roush Package


WHERE EVER YOU GO....THERE YOU ARE
dennis b is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Jayco, Inc. or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.