Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 11-13-2013, 09:27 AM   #1
Senior Member
 
DieselX's Avatar
 
Join Date: Feb 2011
Location: Winston Salem
Posts: 275
poor radio reception

Our 2011 bhds suddenly can't pick up any radio stations. Our truck picks them up and everyone else around us does too. I looked behind the radio the antenna was plugged in properly, anyone else have this problem? Our last campsite didn't pick up (in the same campground) and I thought it was because we were close to some power lines but now we aren't near any. Never had this problem before and we have been full timing for over a year up and down the east coast.

I didn't see any booster or anything, thought it might be something simple like when you leave on the antenna booster for the tv trying to watch cable haha.
__________________

__________________
2011 32bhds
TV 2002 Excursion 7.3 Few mods ;)

DieselX is offline   Reply With Quote
Old 11-13-2013, 11:08 AM   #2
Senior Member
 
DieselX's Avatar
 
Join Date: Feb 2011
Location: Winston Salem
Posts: 275
Okay, went up on the roof, unscrewed the antenna and it was corroded In the ball and socket joint. Soaked it in vinegar and hit it with sandpaper added some grease and now have 3 stations.
__________________

__________________
2011 32bhds
TV 2002 Excursion 7.3 Few mods ;)

DieselX is offline   Reply With Quote
Old 11-13-2013, 11:11 AM   #3
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
[ATTACH][/ATTACH]
Threebutchers is offline   Reply With Quote
Old 11-13-2013, 04:30 PM   #4
Site Team
 
norty1's Avatar
 
Join Date: Jan 2011
Location: Charleston, SC
Posts: 12,046
Thanks for the tip. I never thought to clean and lube up there. Will try it and see if it helps.
__________________
Moderator
2011 351RLTS Eagle, Mor/Ryde suspension & pin box
06 F350 Lariat PSD, SRW, LB, CC, EGR delete kit, 16K DrawTite hitch, Timbrens, TST TPMS

Can't find what you're looking on JOF? Try:Jayco Owners Forum Custom Google Search
"It's easier to fool people than to convince them that they have been fooled." - Mark Twain
norty1 is offline   Reply With Quote
Old 11-13-2013, 04:34 PM   #5
Site Team
 
Crabman's Avatar
 
Join Date: Nov 2010
Location: Virginia`s Eastern Shore
Posts: 14,654
Mine has never had very good reception since new, only the closest of stations will come in.
__________________
2017 Coachmen Catalina 283RKS
2004 Chevy 2500 HD CC 6.0l
2010 Jayflight 28BHS (sold)
Crabman is offline   Reply With Quote
Old 11-13-2013, 07:26 PM   #6
Senior Member
 
DieselX's Avatar
 
Join Date: Feb 2011
Location: Winston Salem
Posts: 275
By all means it's not perfect, but it was a definite improvement and only took a few minutes. Cheers!!
__________________
2011 32bhds
TV 2002 Excursion 7.3 Few mods ;)

DieselX is offline   Reply With Quote
Old 11-14-2013, 08:13 AM   #7
Senior Member
 
RoyBraddy's Avatar
 
Join Date: Sep 2011
Location: King George
Posts: 2,396
I had a similar problem a year or so back and apparently I drug off the AM/FM antenna running down the winding low overhang roads back in the woods. Once I got a new antenna back in place all is well. I added the bend over spring on the the new install. Hopefully the antenna will lay over the next time and spring back up when clear of the low tree branches.

Roy Ken
__________________
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA
RETIRED DOD DOAF DON CONTRACTOR Electronics Tech 42YRS

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote
Old 08-19-2014, 07:35 PM   #8
Junior Member
 
Join Date: Aug 2014
Location: Saskatoon
Posts: 7
I have a 2014 JayFlight and have had terrible reception since day one.

FM will come in parked in the city. AM is real sketchy. Out at the lake, no FM which is no surprise, yet nothing at all for AM. The truck can pick AM and some FM really well (Although, I have been told GMC/Chevy have real good radios).

I took radio out and climbed on roof and antenna seems attached at both ends.

I see others have the same issue. Just wondering if a replacement is an option or should I mention to dealer for warranty?
DirtyBurger2.0 is offline   Reply With Quote
Old 08-21-2014, 01:44 AM   #9
Senior Member
 
Join Date: May 2011
Location: Aldergrove British Columbia
Posts: 815
I've read about owners who have attached their tv antennas to their receivers by using a Motorola to type F connector and have had great results. Not having done this myself I ant say first hand how well it works but a google search may give you a place to start.
__________________

__________________
Richard
2011 Jay Feather Select 28U
2007 Silverado Crewcab LT 6.0L
Happily married and father of
two university students.
Cancer survivor
Murphie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.