Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 01-04-2016, 01:37 PM   #1
Senior Member
 
Swinepartner's Avatar
 
Join Date: Feb 2014
Location: Zebulon
Posts: 169
Seal loose

I have a 15 28BHBE and due to surgery and time, I left the slide open on it since fall. It is parked next to a tree and I needed to get on top and sweep leaves off before retracting the slide. Well, I get up there today and sweep and I see the seal detached and laying on the slide roof. I get down and look at how it is attached at one end it is attached under the "wiper" or sweeper white seal. The black seal is rounded on one end and has two lips on the other side. I push the seal back into place, behind the white "wiper" seal but couldn't find a lip or anything that it attaches to. Sorry I didn't have my phone to take pics. I have been checking inside the camper for water damage and I checked again today. No stains and we in NC have had our share of rain this fall and 3 days last week alone. I did retract the slide today after sweeping the leaves off. I looked on top of the retracted slide and it looked like the seal in question didn't come inside and is pinched between the lip of the slide and the side of the trailer.

Any advice! I'm about to get on YouTube to see if I can learn anything.

Thanks.
__________________

__________________
Kevin "Corndog" Cameron
2016 Ram 2500 CTD TRADESMAN
2015 Jayflight 28BHBE
Swinepartner is offline   Reply With Quote
Old 01-04-2016, 04:22 PM   #2
Senior Member
 
Swinepartner's Avatar
 
Join Date: Feb 2014
Location: Zebulon
Posts: 169
Seal laying out of place on top of slide

http://
__________________

__________________
Kevin "Corndog" Cameron
2016 Ram 2500 CTD TRADESMAN
2015 Jayflight 28BHBE
Swinepartner is offline   Reply With Quote
Old 01-04-2016, 04:32 PM   #3
Senior Member
 
Swinepartner's Avatar
 
Join Date: Feb 2014
Location: Zebulon
Posts: 169
Channel end of seal

http://


Top rounded side of seal
http://


Seal at aft end of slide
http://
__________________
Kevin "Corndog" Cameron
2016 Ram 2500 CTD TRADESMAN
2015 Jayflight 28BHBE
Swinepartner is offline   Reply With Quote
Old 01-04-2016, 04:45 PM   #4
Senior Member
 
Join Date: Aug 2015
Location: Albany, OR
Posts: 589
I have the exact same issue on mine. It is caused because the channel piece is not installed strait and is slightly wider in some places than in others.
I have to get up on a step stool every time I close the slide and put the seal back in the channel, otherwise it would do what yours did and get under the wiper seals.
I am still debating whether to glue it in place somehow or make them take the old channel completely out and replace it. Unfortunately the channel piece is not too easy to get at, with the slide installed.
__________________

2015 Jayco 27RLS
2015 Ford F250 6.7PSD
DanNJanice is offline   Reply With Quote
Old 01-04-2016, 04:58 PM   #5
Senior Member
 
Swinepartner's Avatar
 
Join Date: Feb 2014
Location: Zebulon
Posts: 169
Thanks Dan. I stil have a year left on warranty work, so I'll prob take it back to the dealer to fix right before the warranty expires, prob this spring before we hit the road hot n heavy.

So, yours isn't leaking either?
__________________
Kevin "Corndog" Cameron
2016 Ram 2500 CTD TRADESMAN
2015 Jayflight 28BHBE
Swinepartner is offline   Reply With Quote
Old 01-04-2016, 05:21 PM   #6
Senior Member
 
Join Date: Aug 2015
Location: Albany, OR
Posts: 589
Quote:
Originally Posted by Swinepartner View Post
Thanks Dan. I stil have a year left on warranty work, so I'll prob take it back to the dealer to fix right before the warranty expires, prob this spring before we hit the road hot n heavy.

So, yours isn't leaking either?
No, I noticed the seal issue before it got under the wiper and now I always make sure the seal is back in the channel before I put the slide all the way out. Also, unless we are camping the slide is always closed so the seal in question is not used.
__________________

2015 Jayco 27RLS
2015 Ford F250 6.7PSD
DanNJanice is offline   Reply With Quote
Old 01-04-2016, 05:30 PM   #7
Senior Member
 
Join Date: Aug 2015
Location: Albany, OR
Posts: 589
Quote:
Originally Posted by Swinepartner View Post
Thanks Dan. I stil have a year left on warranty work, so I'll prob take it back to the dealer to fix right before the warranty expires, prob this spring before we hit the road hot n heavy.

So, yours isn't leaking either?
Here is what I was talking about. In this picture I think you can actually see where the channel is a bit wider in some places.
__________________

2015 Jayco 27RLS
2015 Ford F250 6.7PSD
DanNJanice is offline   Reply With Quote
Old 01-04-2016, 05:40 PM   #8
Senior Member
 
oldmanAZ's Avatar
 
Join Date: Dec 2014
Location: AZ
Posts: 7,039
@Swinepartner & @DanNJanice

I'll have to take a GOOD hard look at my 2015 Jay Flight slide seal. It was popped out of the channel when my smoke detector fell from the ceiling, onto the top of the slide, and went out through the seal and back in again. The dealer reinstalled the seal, but I haven't given it much of a thought until seeing these.

(BTW: Now I install the smoke detector when we run the slide out and remove it just before running the side back in.)
__________________
Sherm & Terry w/rescues Eydie (min Schnauzer) Steve RIP (std Poodle)
2015 Jay Flight 27RLS (Camped: 102 nights '15, 90 nights '16, 70 nights '17 so far)
2006 Ford F350 6.0 PSD, Lariat, 4WD, CC, LB, SRW, auto., Camper pkg.
oldmanAZ is offline   Reply With Quote
Old 01-04-2016, 07:53 PM   #9
Senior Member
 
BigJohnD's Avatar
 
Join Date: Nov 2014
Location: Florien, LA
Posts: 1,709
I've always just used some silicone or appropriate adhesive sealer to make them stay / stick in the track. Easy fix. I think the double wiper is of the "H" type / one piece, so I'm all for making the bulb seal stay opposed to removing the H seal. Just count the staples. If done right, all is well, if not done right, you'll have a whole new set of problems. Just my 2 cents. BTW, my bulb seal originally came loose on one end as well. Hadn't since.
__________________
John and Rebecca Dickson
Emma-9 / Little John-6 / Iva-2
2013 Ford F-350 Lariat FX4, CC LB PSD, DRW
2015 Jayco Jay Flight 28BHBE (#8)
BigJohnD is offline   Reply With Quote
Old 01-04-2016, 08:57 PM   #10
Senior Member
 
Join Date: Aug 2015
Location: Albany, OR
Posts: 589
Quote:
Originally Posted by BigJohnD View Post
I've always just used some silicone or appropriate adhesive sealer to make them stay / stick in the track. Easy fix. I think the double wiper is of the "H" type / one piece, so I'm all for making the bulb seal stay opposed to removing the H seal. Just count the staples. If done right, all is well, if not done right, you'll have a whole new set of problems. Just my 2 cents. BTW, my bulb seal originally came loose on one end as well. Hadn't since.
The seal looks like the drawing below. Any thoughts on what might be an appropriate adhesive? I am trying to decide if I should use something that really sticks like Liquid Nails, 5200, Epoxy, etc or something like silicon caulk that I might be able to remove if needed.
__________________

__________________

2015 Jayco 27RLS
2015 Ford F250 6.7PSD
DanNJanice is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.