Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-29-2014, 10:12 PM   #1
Senior Member
 
Join Date: Nov 2013
Location: Fraser Valley
Posts: 306
Update on Faulty AC

Our maiden voyage revealed that the AC wasn't cooling. The fan worked fine, but the unit wasn't cooling the air.

Took it in (under warranty) and the verdict seems to be that the thermostat switch isn't working. So another one is on order. Living in the Yukon, we can survive without AC, but we are heading out for a trip to very warm climates later this summer so we gotta get this sucker working!

It's frustrating, but not much we can do about it.
__________________

__________________
Proud Yukoner
2010 Ford F-150 Supercrew Lariat
2016 Whitehawk 27 DSRL
2014 Jayflight 24FBS Elite (Sold)
ykcamom is offline   Reply With Quote
Old 05-30-2014, 12:02 AM   #2
Senior Member
 
Join Date: Dec 2010
Location: North Idaho/Arizona
Posts: 5,303
Hopefully it will be a painless fix.
__________________

__________________
2011 Eagle 330RLTS with just about every option.
2017 Silverado 1500 4x4 5.3 with tow package.

I was born with nothing and I still have most of it left.
clutch is offline   Reply With Quote
Old 05-30-2014, 05:44 AM   #3
Senior Member
 
Threebutchers's Avatar
 
Join Date: Mar 2013
Location: Planet Earth
Posts: 6,818
Thanks for the update....good luck!
Threebutchers is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.