Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-19-2014, 08:31 PM   #1
Senior Member
 
ninjahbob's Avatar
 
Join Date: May 2014
Location: Eatonton
Posts: 305
Vinyl or plastic taste in our new MRB20

We can't get the odor or taste out of the water in our new TT. It taste and smells like vinyl or plastic. I have eliminated the supply hose. Anyone have a solution?
__________________

ninjahbob is offline   Reply With Quote
Old 08-19-2014, 08:45 PM   #2
Senior Member
 
glsimms's Avatar
 
Join Date: Jun 2012
Location: Southern Indiana
Posts: 1,325
Might want to try an RV water filter. I use one by camco you can buy just about anywhere.....

Wally World, Camping World, etc.
__________________

__________________
2017 Some Other Brand (SOB)
2013 Jayco Jay Feather X23B (She Gone)
2014 Ford Expedition
Gerard
glsimms is offline   Reply With Quote
Old 08-19-2014, 08:50 PM   #3
Senior Member
 
Join Date: Sep 2013
Location: South Texas
Posts: 4,190
Have you tried sanitizing the system? Also make sure you're using a high quality city water hose.

I bet if you sanitize and flush plenty of water through the system it'll be right.
__________________


2014 Jay Flight 28 BHBE
2015 RAM 2500 6.4L HEMI, Tradesman 4x4, 3.73
Blue Ox SwayPro (BXW 1503)

Upgraded from an REI internal frame backpack and a Eureka 1/2 dome tent!
Camper_bob is offline   Reply With Quote
Old 08-19-2014, 09:29 PM   #4
Senior Member
 
Ustabslim's Avatar
 
Join Date: Aug 2014
Location: Spicewood, Texas
Posts: 918
Flush good with bleach. And as stated above a good inline water filter and RV hose..not just any water hose.
__________________
2015 338RETS Eagle Premier gloss sides., king.
2012 Ram 3500, crew cab 4x4 duelly Deleted
16k miles, 530HP, 1000 +torque.
Ustabslim is offline   Reply With Quote
Old 08-20-2014, 06:42 AM   #5
Senior Member
 
ninjahbob's Avatar
 
Join Date: May 2014
Location: Eatonton
Posts: 305
I have drawn water directly from my hose that connects to the TT. I get no odor at that point. I have not sanitized the unit other then flushing with good clean water. Is bleach the product to use throughout the unit system?
Thank you for your response.
ninjahbob is offline   Reply With Quote
Old 08-20-2014, 07:01 AM   #6
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,045
The directions to sanitize the tank are in the owners manual. A cup of bleach in the tank fill with water. Run the pump and open each faucet until you smell the bleach water. Let is sit overnight. Drain, fill with fresh water and run through faucets till bleach odor is gone. Drain, fill and repeat.
__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is offline   Reply With Quote
Old 08-20-2014, 07:08 AM   #7
Senior Member
 
Ustabslim's Avatar
 
Join Date: Aug 2014
Location: Spicewood, Texas
Posts: 918
^^^^yes, but as I had to flush afterwards I used whole gallon to make sure I was one and done.
__________________
2015 338RETS Eagle Premier gloss sides., king.
2012 Ram 3500, crew cab 4x4 duelly Deleted
16k miles, 530HP, 1000 +torque.
Ustabslim is offline   Reply With Quote
Old 08-20-2014, 08:55 PM   #8
Senior Member
 
cekkk's Avatar
 
Join Date: Nov 2010
Location: Murrieta
Posts: 2,421
I use a quarter cup Clorox per 15 gallons of water, the typically recommended ratio. I just wouldn't feel comfortable using 15 or 20 times that ratio. Seems like it would take a whole bunch of rinsing and flushing.
__________________
'11 Eagle 320RLDS
'02 F350 PSD Dually 4WD
DW's Ride, '13 Expedition
cekkk is offline   Reply With Quote
Old 08-23-2014, 12:41 PM   #9
Senior Member
 
ninjahbob's Avatar
 
Join Date: May 2014
Location: Eatonton
Posts: 305
Flushed the tanks with bleach opened all valves will know tomorrow if he odor goes away. thanks for all of the advice. I will post the results.
ninjahbob is offline   Reply With Quote
Old 12-25-2014, 07:33 PM   #10
Senior Member
 
ninjahbob's Avatar
 
Join Date: May 2014
Location: Eatonton
Posts: 305
The bleach cleaned some of the odor out but what worked best was opening the gray water outlet along with the sinks and showers and letting the water run for the day. All is well now.
__________________

ninjahbob is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.