Jayco RV Owners Forum
 



Reply
 
Thread Tools Display Modes
 
Old 04-30-2018, 08:02 PM   #1
Junior Member
 
Join Date: Apr 2018
Location: San Antonio
Posts: 2
Exclamation Water Heater Does not Start

We have a 2018 Jayco Travel Trailer. The water heater does not want to tun on. I hear it wants to start, but after a few tries it stops. The gas stove is working so I think we have gas. Any ideas?
__________________

Bereniceyormany is offline   Reply With Quote
Old 04-30-2018, 08:07 PM   #2
Senior Member
 
Cannon's Avatar
 
Join Date: Feb 2018
Location: Palmetto
Posts: 267
Make sure it is full of water and not in bypass.
__________________

__________________
2017 377rlbh
Cannon is offline   Reply With Quote
Old 04-30-2018, 09:19 PM   #3
Member
 
Join Date: Jan 2018
Location: Sterling
Posts: 32
https://www.jaycoowners.com/forums/f...-new-post.html

I’m assuming you might have the gas only model.
damammel is offline   Reply With Quote
Old 04-30-2018, 09:31 PM   #4
Junior Member
 
Join Date: Apr 2018
Location: San Antonio
Posts: 2
Quote:
Originally Posted by damammel View Post
https://www.jaycoowners.com/forums/f...-new-post.html

Iím assuming you might have the gas only model.
Yes. It is gas. We check the Gas and it has Gas. We check Water tank and it has Water. I hope it is cover under the Warranty. For now I guess cold Water only.
Bereniceyormany is offline   Reply With Quote
Old 04-30-2018, 10:23 PM   #5
Member
 
Join Date: Aug 2017
Location: Spanaway
Posts: 54
Quote:
Originally Posted by Bereniceyormany View Post
Yes. It is gas. We check the Gas and it has Gas. We check Water tank and it has Water. I hope it is cover under the Warranty. For now I guess cold Water only.
But doe's it have enough air? You may want to check into how to adjust the venturi on it and also check that it's clean and clear of debri, insects are attracted to propane so it's very possible you have a blockage in the venturi.
__________________
2016 Ford F150 XLT S-CREW Long Bed 3.5L EcoBoost.
2007 Jayco JayFlight 23FB

JeremyFr is offline   Reply With Quote
Old 05-01-2018, 02:41 AM   #6
Member
 
Join Date: Jan 2018
Location: Sterling
Posts: 32
Have you tried to light it manually? I have had 2 boards fail. The first one I was able to use the grill lighter to ignite the gas while it was trying to start. Once running it would stay on till the water was hot. The second board would only run for a few seconds no matter what. There are two little lights on the board that you should see light up when the heater is trying to start. It shows that the boards igniter is working. When the first board failed I did go through all the checks such as spark gap and air/gas flow. The spark gap is in the owners manual for the heater.
damammel is offline   Reply With Quote
Old 05-05-2018, 01:52 AM   #7
Junior Member
 
Join Date: Nov 2017
Location: Joplin
Posts: 8
Agree with damammel! My board failed too. 2018 BHS Dealer knew of board issue on Atwood WH. Changed board and ran fine
Davetheslave
Davetheslave is offline   Reply With Quote
Old 05-11-2018, 10:41 AM   #8
Junior Member
 
Join Date: Oct 2017
Location: Smyrna
Posts: 2
It’s your control board. Atwood is aware of a bad batch of boards. We’re on our 4th board now. Keeping our fingers crossed this one isn’t bad too. So far so good.
jhw1022 is offline   Reply With Quote
Old 05-11-2018, 06:20 PM   #9
Senior Member
 
Join Date: Jun 2014
Location: Highland
Posts: 316
A trick i heard about last year and it worked. Turn it on. Go out side and put your hand over the exhaust pipe. Wait for it to fire. Then you will be good. Blew my mind. But it worked. Give it a try
__________________
Chris Moore
2010 Starcraft/Jayco 297BHS pulled by
2009 Chevy Silverado
chrismoore701 is offline   Reply With Quote
Old 05-11-2018, 10:38 PM   #10
Member
 
Join Date: Jan 2018
Location: Sterling
Posts: 32
That trick may work for some situations but with these failures there is no spark and gas only stays on for a few seconds if you use a lighter. The board controls both these functions.
__________________

damammel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.