Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 06-23-2013, 03:09 AM   #1
Junior Member
 
hoehn19's Avatar
 
Join Date: Apr 2013
Location: Ohio
Posts: 17
Angry Water pump issue

I have a 08 jayflight 26bh and went ahead and sanatized my lines due to a sulfery black water coming out. Well I had assistance because I'm new to this and thought my help knew his stuff. Long story short the water pump would kick off after the lines were full prior to sanatizing. My help used both gravity fill and city lines to fill tank and lines. After the tank was full he opened the faucets and water heater and let drain completely. My help left the pump on after empty for approx 15 minutes and when we will up again the water pump will not shut off. We were able to get water to the faucets but can't get pump to stop. All lines are open properly(I think) and water is in the hot water heater just not getting proper pressure like before. PLEASE HELP!!!


Thanks in advance
Clueless!!
__________________

hoehn19 is offline   Reply With Quote
Old 06-23-2013, 04:31 AM   #2
Senior Member
 
tnchuck100's Avatar
 
Join Date: Jun 2012
Location: Sparta, TN
Posts: 1,174
The pump should be able to run dry without damage. However, if you are disconnected from city water and the fresh water tank has sufficient water in it and the pump is pumping water from the faucets and the faucets are shut off and there are no leaks anywhere the pump is likely bad.

One possibility to check for a loose connection between the pump intake and the tank. If it is sucking air this could happen. If you have a winterizing tube at the pump check to be sure that valve is completely closed.
__________________

__________________
Chuck - Sparta, TN
2012 Jay Flight 22FB, 2 x Honda EU2000i
2013 GMC Yukon XL Denali AWD

EDUCATION is what you get when you read the fine print.....
EXPERIENCE is what you get when you don't.
tnchuck100 is offline   Reply With Quote
Old 06-23-2013, 07:18 AM   #3
Junior Member
 
hoehn19's Avatar
 
Join Date: Apr 2013
Location: Ohio
Posts: 17
If it helps the noise it makes is a low hum compared to the normal noise it makes. Also there does not appear to be any leaks. Does anything special have to be done to my hot water heater
hoehn19 is offline   Reply With Quote
Old 06-23-2013, 10:53 AM   #4
Senior Member
 
Join Date: Dec 2012
Location: Southern Indiana
Posts: 1,354
Turn the pump switch off. Make sure the fresh tank has sufficient water in it to pump. My pump will make a low hum sound if there isn't enough water to pump. {you're pumping air instead of water}. When the fresh tank is full, turn the pump back on. The water heater will fill first and at 6 or 10 gallons, this takes a short while. Make sure all faucets, outdoor shower and low point drains are closed. If it still won't pump up, walk around the outside of your camper while the pump is still running to see if any water is coming out from any orifice. If not, Chuck is probably correct, the pump went bad.
TCNashville is offline   Reply With Quote
Old 06-23-2013, 12:29 PM   #5
Senior Member
 
Join Date: Jul 2012
Location: New Haven, NY
Posts: 807
When trying to prime the pump you might need to open one of the cold water faucets to purge the air.
__________________


2017 28BHBE Kitchen skylight, remote control and Aluminum wheels hitched by ProPride 3P
2017 Ram 2500 CC LB 4x4 Big Horn Cummins
LiftedAWDAstro is online now   Reply With Quote
Old 07-01-2013, 02:18 PM   #6
Junior Member
 
hoehn19's Avatar
 
Join Date: Apr 2013
Location: Ohio
Posts: 17
Just an update. After tightening every hose clamp and several choice words to the water pump... I re doped the water heater plug and my troubles are over!
hoehn19 is offline   Reply With Quote
Old 07-01-2013, 08:11 PM   #7
Senior Member
 
Join Date: Apr 2013
Location: Cleveland
Posts: 1,435
Double check that the valve on the pickup tube between your fresh water tank and the pump is open. I had a similar problem and found that the valve had been bumped closed so the pump wasn't getting any water.
__________________

__________________
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.