Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-19-2015, 12:08 AM   #1
Junior Member
 
Join Date: Aug 2015
Location: elk point
Posts: 1
interior plug ins not working

Hi all,
First trip for me and my son in our 2006 jayco select 12hw trailer. Just running on battery power. Lights work, stereo works (is lit up) but there is no power to the plug ins. I hit the test and reset button on the gfci and looked at the breakers and fuses. Any suggestions?
__________________

euphoria18_79 is offline   Reply With Quote
Old 08-19-2015, 05:10 AM   #2
Senior Member
 
Join Date: Apr 2015
Location: Elizabethtown, PA
Posts: 1,542
If you are just running off the battery The only items that will have power are those that require 12 Volts and your Plug ins require 120 Volts and that means either being plugged into shore power or a generator.
__________________
2004 Jay Feather 25E
2001 Ford Expedition 4X4 EB 5.4 3.55 rear
2004 Ford Expedition 4X4 EB 5.4 3.73 rear
bedrck46 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.