Jayco RV Owners Forum

Jayco RV Owners Forum (https://www.jaycoowners.com/forums/)
-   Jayco Fifth Wheels (https://www.jaycoowners.com/forums/f6/)
-   -   RE:Schwintech on Jayco (https://www.jaycoowners.com/forums/f6/re-schwintech-on-jayco-10469.html)

Cruzinfools 11-29-2012 06:28 PM

RE:Schwintech on Jayco
 
On the new Jayco's have they had any trouble with the new Schwintech on there slideouts? I have seen other brands has had all kinds of troubles. The new Jayco I have on order has 2 of them I know it is to late to worry about this now but was just wondering.

Rustic Eagle 11-29-2012 06:34 PM

I've heard of some isolated cases (not just Jayco), but for the most part they have been trouble free. My BIL has them on his 2012 Eagle FW and didn't have any issues all season.

Bob

norty1 11-29-2012 07:53 PM

I have one on my BR slide. Trouble free in 1/1/2 years.

taviking22 11-29-2012 08:42 PM

I have 2 Schwintech slides which have performed trouble-free during their first year of use. I read somewhere...can't remember (darned sometimers!) that it is important to keep the worm tracks clean of debris. If you google "Schwintech slide" you'll get quite a bit of info.

kbaum13 11-29-2012 08:54 PM

What model have you ordered? We are new owners ourselves and have not had any problems but have read on rv.net of several problems as usual the problems get the press when working properly not much is said.

bad99ram 11-30-2012 05:12 AM

On my 2010 321RLMS I had nothing but trouble with the Monster Slide that had that system. However, my 2013 351MKTS I have two of them that have been trouble free thus far.

Rob_Fla 11-30-2012 05:39 AM

The Schwintek system on our Bedroom Slide has worked great.

The Schwintek system on our large slide with the Entertainment Center, Stove, Microwave and Refig struggles to work.
When ever we operate the large slide we have to make sure the trailer is level front to rear and side to side or one side will drag and the slide will jam.
We also make sure we are plugged up to power before operating the slide to make sure we have full voltage.

Now that we have learned what to do and not do when operating the large side by making sure it is level and keeping a eye on the tracks for debris it has worked everytime although it still seems to struggle.

rbrumfield 11-30-2012 06:16 AM

How can you tell if your RV has this slide system?

Rustic Eagle 11-30-2012 06:40 AM

The Schwintek In-Wall slide as a rail mounted at the top and bottom of the slide ends that looks like this:

https://www.jaycoowners.com/attachmen...8e2864b4fb.png

jal0710 11-30-2012 07:00 AM

Somewhere in the thread below regarding problems you can find my post from last spring when I had, for me, a bunch of problems with my wardrobe slide in my 2012 HT 26.5 RLS. Three trips to the dealer but I do believe they finally got it fixed/adjusted as it worked great every time since, including three trips to Grand Teton National Park this summer and numerous ins and outs when stored next to the house. I really like the concept of the system, just think they may have had some problems with the installation at the factory early on.


All times are GMT -6. The time now is 12:48 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.