Jayco RV Owners Forum

Jayco RV Owners Forum (https://www.jaycoowners.com/forums/)
-   Jayco Lite/Ultra Lite Travel Trailers (https://www.jaycoowners.com/forums/f32/)
-   -   Getting heater oils burned off (https://www.jaycoowners.com/forums/f32/getting-heater-oils-burned-off-22839.html)

NevadaCamper 10-03-2014 08:24 PM

Getting heater oils burned off
 
I have tried a couple of times to use the heater in my 185RB, It is supposed to burn off the oils and set off the smoke detector at first. It is still doing it. Should I turn it on and let it alarm until it stops??

nbhybrid 10-03-2014 08:30 PM

Quote:

Originally Posted by NevadaCamper (Post 239943)
I have tried a couple of times to use the heater in my 185RB, It is supposed to burn off the oils and set off the smoke detector at first. It is still doing it. Should I turn it on and let it alarm until it stops??

how about you let it get hot and remove the alarm or its battery

Jagiven 10-03-2014 09:10 PM

It will take about 30 minutes of run time to burn off the manufacturing oils. Then a few hours to air out the to. I would recommend removing the battery to the smoke alarm and leave the door and windows open.

Camper_bob 10-03-2014 09:35 PM

When I did mine, I opened up all the windows and doors and the ceiling vent. I ran it for about an hour, no alarms, and all the smells were gone when I finished.

namusmc65 10-04-2014 08:35 AM

In all the Jayco units I have owned, I have never had this problem. Always ran the furnace for the first time with no problems at all. Some smell obviously the first couple of times but never set off any detection systems. I would vent the area real well and try again and remove the smoke detector batteries as some have said.

Ustabslim 10-04-2014 08:44 AM

My dealer did mine in the PDI, as well as all the ones I've purchased in the past 10-15 years. I've never had the problem. So for that reason I'm not interested.....wait...this isn't Shark Tank....

NevadaCamper 10-04-2014 07:08 PM

Thanks for all the replies. I took the advice and just opened all the windows and vents turned it on and waited for the alarm to stop. It seems like it is all good now. To the Admin....sorry I put this thread on twice I had a brain fart...lol...Again you guys are great and I am learning to be a top notch camper a little at a time. Going to Davis Creek Campground, New Washoe City, NV for my next outing.


All times are GMT -6. The time now is 05:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.