Jayco RV Owners Forum

Thread Tools Display Modes
Old 06-08-2011, 09:44 AM   #21
Junior Member
Join Date: May 2011
Posts: 9
I had my slide motor breakdown and replaced twice on my 2011 unit. It appears to be a china made motor but the last time it was the controller also. Don't know where the newest one was made but so far so good after the first trip.

lowfly is offline   Reply With Quote
Old 06-09-2011, 03:38 PM   #22
lovecamping's Avatar
Join Date: Mar 2011
Location: Utah
Posts: 40
While we are talking about slides, I have a little problem. I have a 32BHDS which has 2 slides. Well, the rear slide is not going out properly. The front side of the slide does not seal to the inside of the camper, there is about 1 inch of space there, and I can feel a good breeze through it. When I close the slide it seals perfectly. I don't understand why it would have torqued and only has an issue when the slide is out.

It seems like one motor is not running as fast as the other or something. Aligned when it is in, and misaligned when it is out...Anyone else have that trouble before? I can take it to the dealer, but as others have mentioned, I dont want to wait weeks for a repair if I can do it myself in a couple days.

Thanks in advance.

Jake, Alicia, 6 kids, 1 dog
F250 SD 7.3L
Jayco G2 32BDHS
lovecamping is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 04:26 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.