Jayco RV Owners Forum

Thread Tools Display Modes
Old 09-18-2016, 06:50 PM   #1
Junior Member
Join Date: Sep 2016
Location: Macon
Posts: 1
New X19H Owner

Really great to find a forum for all us Jayco owners. Just took my 2017 X19H on our first trip and had some issues. Is there some secret to getting the hot water to come out of the faucets. Not only could I not get hot water but I couldn't get any water to come out of the faucet when using the hot water handle. Not kitchen or bathroom or shower. No problem with cold water. Hot water heater works as far as I could tell. At least the flame came on and went off like it should. I suppose it could be operator error but I don't really see how. Any ideas? Enjoyed the trip to Florence Marina St. Park in Omaha, Ga which is close to Columbus. Visited Providence St Park which is the home of the Ga Grand Canyon. Really neat place.

thmoose51 is offline   Reply With Quote
Old 09-18-2016, 07:45 PM   #2
Senior Member
Join Date: Apr 2013
Location: Cleveland
Posts: 1,415
Check the winterization valves on the pipes leading to the back of the water heater. The top and bottom valves should be open and the vertical "bypass" valve should be closed.
2013 Jayco JayFlight 26RKS
2013 Ford F150 Ecoboost FX4

2003 Coleman Bayside / 2011 Jayco Jayfeather X20E -- RIP
2012 Tacoma Sport DCSB / 2013 Tundra SR5 - RIP
Heady is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:09 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.