Jayco RV Owners Forum

Thread Tools Display Modes
Old 04-02-2012, 03:10 PM   #1
Junior Member
BucknWinkie's Avatar
Join Date: Feb 2012
Location: Minneapolis
Posts: 6
Peeling/fraying decals on 2011 X19H

FYI: We bought a new 2011 JayFeather Select X19H last May and noticed that the decals are peeling on the front of the camper. We took it to our dealer right away and they actually weren't surprised.

Apparently they've already had to replace the decals on several others. They're not sure why it's happening, but it may possibly be the glue used on the decals. They're looking into it and they'll let us know, so we'll add more to this topic once we get our camper back. ;-)

BucknWinkie is offline   Reply With Quote
Old 04-02-2012, 03:20 PM   #2
Join Date: Jan 2012
Location: Norwood, New York
Posts: 82
Mine are starting to lift also- 2012 x17z.

Rick56 is offline   Reply With Quote
Old 04-02-2012, 04:53 PM   #3
Join Date: Mar 2012
Location: minnesota
Posts: 33
ours were peeling when we picked it up on 3/22 from the dealer. All the new ones on the lot were peeling. All the dealer should be aware of it. They told us they would let us know when the new ones came in. Maybe just take them off and forget it.
dedeanddon is offline   Reply With Quote
Old 04-02-2012, 09:03 PM   #4
Senior Member
Join Date: Feb 2012
Posts: 474
Mine were the same, they were pealing when I picked up my 2011 23j. The dealer said there is a recall on them and will be replaced once they get them in.
slabat is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:18 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.