Jayco RV Owners Forum

Thread Tools Display Modes
Old 04-11-2014, 05:28 AM   #11
Junior Member
Join Date: Feb 2014
Location: Keswick
Posts: 26
Egg on my face ?? Well, the problem was in the fuse rating: As mentioned in my original post there was a 30 amp fuse in the holder, reading the one page brochure it said 20 amp circuit breaker so, I put in a 20 amp fuse and it blew. The dealer could not explain why it was not connected to the battery but put a 30 amp fuse in the holder and all's well. the question was asked about the brochure and no reason was given other than a trip over to another TT unit and it had a 30 amp fuse in the holder?? The trip was not a waste as one of the inside wall seams was bulging about a foot down the side by the bed. They pulled the strip of tape off, stapled the bulge back to the 2x2 and re-taped it, all's well. Next trip planned to Douthat State park in Va in a week and a half

J & J
2012 Chevy Silverado Ext Cab, 5.3L, 3.42 Ratio, HD trailer Pkg
R2 Hitch & sway control
2014 Jayco 22FB
Fishnmagician is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.