Jayco RV Owners Forum

Thread Tools Display Modes
Old 10-12-2016, 08:42 PM   #1
Junior Member
Join Date: Jul 2016
Location: Whitefish
Posts: 4
Winterizing Problem

Ok, first time winterizeing my Jayco Melbourne 29D. Drained all tanks, shut off hot water. The water filter under sink has no cut off valve. No way to bypass it. So I said screw it. Went to water valves and put them, on winterize. 2 and 4. Put hose on inlet and into antifreeze bottle. Turned on pump...no suction on antifreeze ???? Ran for a long time....no suction. Went on line, read about the filter on the inlet. It was installed with dome out. Ok, took it out completely. Still no suck. What is correct way for the filter dome to be. Facing in towards couch or out toward me to allow suction??

Lakota is offline   Reply With Quote
Old 10-13-2016, 01:54 AM   #2
Junior Member
frog's Avatar
Join Date: Dec 2015
Location: Newark,Delaware
Posts: 28
Send a message via Yahoo to frog
ON my Redhawk no pump action too! I bought a hand pump and proceeded manually. Still not a piece of cake. If you use a hand pump make sure you use hose clamps on all hose connections cause pressure build up blows hose off pump and can get messy. But it gets it done!!

frog is offline   Reply With Quote
Old 10-13-2016, 04:53 AM   #3
Join Date: Oct 2013
Location: Central Wisconsin
Posts: 94
Lakota, do not take the inlet screen out completely. Turn it around with dome in. This will open the pressure valve inside and allow the pump to siphon the anti-freeze. Remember to turn the washer/dome back around when completed.
2015 Jayco Greyhawk 29KS
Roadmaster 2000-1 Tow Dolly
JulieMike is offline   Reply With Quote
Old 10-13-2016, 07:32 AM   #4
Senior Member
Join Date: Jan 2011
Location: Vienna
Posts: 1,454
I have also found that if the pump is not used for some time, the seals somewhat dry out and don't want to create a suction. What I have done in that case is take a funnel and pour some antifreeze down the suction hose to get it started. I then stick the hose in the bottle and works well for me.

Joe Hinson
2010 Jayco Quest G2(SOLD)
2014 Jayco Eagle 33.5RETS
2007 Ram 2500 5.9L Cummins(SOLD)
2015 Ram 2500 6.7L Cummins 4WD
namusmc65 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.