Jayco RV Owners Forum

Thread Tools Display Modes
Old 01-26-2015, 08:47 PM   #11
Junior Member
Join Date: Dec 2014
Location: Commerce city
Posts: 13
We just bought a 2015 27.5 BHS and can't love more! We tow it with a 2009 Lariat in Colorado and it's doing great so far! We installed airbags as well. No problems yet to report. You'll love it! Congrats!

Flygirl is offline   Reply With Quote
Old 01-27-2015, 02:57 AM   #12
Junior Member
Join Date: Aug 2014
Location: Phoenix
Posts: 22
Originally Posted by SGT View Post
Hello all. New to the forum as we just returned to camping after a 12 year hiatus. Went from a Jay Series 1208 popup to an Eagle 12SO (our first slide out!) back when the kids were small. Now that they are grown we are back into camping with a 2015 Eagle HT 27.5 RLTS. Just finished our first trip and it was wonderful. Got a lot of oohs & aahs from the other campers since we had the "New One". Pulled great behind my '06 F150 Lariat Super Crew 4x4. Looking for any other HT owners to share their experiences so far. Thanks!
Welcome and have a great time with new Eagle.

Originally Posted by rryman View Post
We just got our 27.5 RLTS yesterday, It's a "used" 2014. Previous owner had it 3 months and traded it back in, but that's a whole nother story! Anyway, the only thing I can't get working is the remote control for the slides. They all work from the control panel, but the remote isn't cooperating. Looking at the back of the remote, it talks about the transmitter and relay "learning" process. Is there some relays tucked away somewhere in this unit that need to be programmed?? Only instructions I have are on the back of the remote. When I push the "on" button, a blue light flashes but nothing happens. Any advice would be appreciated.
Change the battery in remote 4 screws on back. Go to walmart and get a new one. The ones they ship with are junk. Happened to mine also. Should fix your problem. From top of my head they are a small short fat battery maybe 24c or c24.


2014 26.5RKS 5er
2008 GMC 3500 Duramax
B&W Companion Hitch
catch5steve is offline   Reply With Quote
Old 01-27-2015, 12:38 PM   #13
Senior Member
rryman's Avatar
Join Date: Jan 2015
Location: Harrisonburg, Va
Posts: 242
Hey Steve,
Your information was spot on-the remote needed a new battery. Thanks for the help. Everything seems to work OK. However, I didn't fully retract the slides due to possible snow on top of them at the moment. I appreciate all the advice. After searching, I also found the remote relay control panel in the storage compartment behind a panel. Hopefully won't have to get into that anytime soon!

Randy, Karen & Abby (Pom-a-Poo)
2014 Eagle HT 27.5RLTS
2015 F250 Super duty 6.2L full trailering pkg.
Shenandoah Valley of Virginia
rryman is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.