Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-07-2016, 07:06 AM   #1
Senior Member
 
Join Date: Feb 2014
Location: Pembroke
Posts: 158
TV Not Working

Have an Eagle HT 28.5 RSTS and tv doesn't work when I have it plugged into my house current. Had a X23B previously and the tv worked on house current. Any reason why this is happening?
__________________

richie t is offline   Reply With Quote
Old 08-07-2016, 07:32 PM   #2
Senior Member
 
rthibodaux's Avatar
 
Join Date: May 2011
Location: Marrero,la
Posts: 141
check GFCI
__________________

__________________
Randy T
Marrero,La
2011 Jayco Eagle 321RLTS FW
2012 Dodge 3500
US Govt survey shows three out of four people make up 75% of the total population
rthibodaux is offline   Reply With Quote
Old 08-07-2016, 08:39 PM   #3
Senior Member
 
Wrascal's Avatar
 
Join Date: Oct 2014
Location: Lower Alabama (LA)
Posts: 1,635
Oftentimes I wish there was a standard way to identify the difference between the abbreviations tv/TV; we've got both "television" and "tow vehicle" often being inter-mingled.

One should always be listed in CAPS and the other only in "lower case". If I was King for the day, month, or year: I would decree TV means tow vehicle, and tv means television.

15 lashes with a wet noodle for the first offense, 1 lash with leather for the second. Big Bertha has her way for subsequent offenses.
__________________
2008 Jayco Eagle SuperLite 29.5
2014 F250 6.7 PSD 4X4, CC LB
Wrascal is offline   Reply With Quote
Old 08-07-2016, 09:18 PM   #4
Member
 
Join Date: Feb 2016
Location: Yellowknife
Posts: 65
Do any of the other 120v outlets work ?

Quote:
Originally Posted by richie t View Post
Have an Eagle HT 28.5 RSTS and tv doesn't work when I have it plugged into my house current. Had a X23B previously and the tv worked on house current. Any reason why this is happening?
__________________
----------------------------------------------
2015 Jayco Eagle HT 29.5BHDS
2016 Ford F350 Lariat

2010 Ford F-250 XLT (traded)
2013 Keystone Laredo 294RK (traded)
ArcticFire is offline   Reply With Quote
Old 08-10-2016, 09:31 AM   #5
Senior Member
 
Join Date: Feb 2014
Location: Pembroke
Posts: 158
You're a genius! It was the GFI. Now the tv is working, but can't seem to coordinate the tv and dvd player. Have sound but no picture. Thanks again!
richie t is offline   Reply With Quote
Old 08-10-2016, 10:24 AM   #6
Member
 
Join Date: Feb 2016
Location: Yellowknife
Posts: 65
Depending on how your tv and dvd player are connected ...... red and white are for audio left and right and yellow is for video.


Quote:
Originally Posted by richie t View Post
You're a genius! It was the GFI. Now the tv is working, but can't seem to coordinate the tv and dvd player. Have sound but no picture. Thanks again!
__________________
----------------------------------------------
2015 Jayco Eagle HT 29.5BHDS
2016 Ford F350 Lariat

2010 Ford F-250 XLT (traded)
2013 Keystone Laredo 294RK (traded)
ArcticFire is offline   Reply With Quote
Old 08-10-2016, 11:32 AM   #7
Senior Member
 
Join Date: Feb 2014
Location: Pembroke
Posts: 158
I believe you are correct. From the dvd player to the tv there are only a red and white connections, no yellow. However the dvd player is installed, and I can't figure out a way to attach the yellow cord because I can't get behind the player to install it.
richie t is offline   Reply With Quote
Old 08-10-2016, 02:01 PM   #8
Senior Member
 
Join Date: Feb 2014
Location: Pembroke
Posts: 158
E-mailed Furrion, and explained my dilemma. They called me and said you have to remove the plastic face plate around the player and remove the screws, which I did. I then connectrd the red,white, and yellow wires from the dvd player to the tv, and it worked. Thanks again! P.S. You would have thought they would have connected it at the Jayco factory.
__________________

richie t is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.