Jayco RV Owners Forum

Thread Tools Display Modes
Old 07-24-2014, 09:58 AM   #1
Junior Member
Join Date: Jul 2014
Location: West Seneca
Posts: 1
Another fuse question please?

I have a 2009 Jayco Jayfeather 213EXP. The plug in fan/light that clicks on the ceiling of the queen bed slide suddenly did not work. Had it tested at the RV dealer where purchased and the unit works just fine.
I believe I have a fuse issue but after removing three suspected fuses I cannot discover the bad fuse.

Does anyone have a copy of the DC fuse panel layout unique to a 213 EXP. The layout in my owners manual is a typical one but not unique.

Any help would be appreciated.

jpope44 is offline   Reply With Quote
Old 07-24-2014, 12:17 PM   #2
Senior Member
RoyBraddy's Avatar
Join Date: Sep 2011
Location: King George
Posts: 2,124
You should be able to get a wiring diagram of your trailer by contacting JAYCO CUSTOMER SERVICE. They are one of the best companies for providing their trailer info.. You will need to have your trailer VIN number handy...

Roy Ken
Roy and Carolyn
I claim Horse Creek Country in Southern Ill - Momabear is from North Texas
We live in King George VA

"We're burning daylight" - John Wayne
2008 STARCRAFT 14RT OFF-ROAD POPUP with PD9260C and three 85AH 12VDC batteries
2010 F150 FX4 5.4 GAS with 3.73 gears - Super Cab - Towing Package - 2KW Honda EU2000i Gen
K9PHT (since 1957) 146.52Mhz
"We always have a PLAN B"
RoyBraddy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:34 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.