Jayco RV Owners Forum

Thread Tools Display Modes
Old 05-27-2014, 07:17 PM   #1
Join Date: May 2011
Location: North Jersey
Posts: 34
Possible Convertor Issue??

I have a 2011 330 RLTS ,I have had a blown fuse issue recently.I replaced the30amp fuse in the fuse holder near battery hook up and will remain ok when used by the battery itself but when I hook up to the main power line not right away but at some point the fuse will blow.Im wondering if there is some possible short with the power convertor.Any hints of what to look for would be appreciated

novaplum is offline   Reply With Quote
Old 05-27-2014, 09:42 PM   #2
Senior Member
Join Date: Jan 2014
Location: Aurora CO
Posts: 2,336
Check all wire terminations and make sure they are clean and tight. ( battery, wires on converter )Check where the battery negative side terminates to the frame ground lug as well

I'm assuming that the battery is in good condition and does not have a bad cell, or that you are not draining it all the way down, then trying to recharge and blowing the fuse because it's drawing more than 30 amps ( my 30.5 has a 45 amp charger)

I'm also assuming you have clean A/C power.
Jim & Kim from Colorado

2014 Eagle 30.5 RLS
2015 Dodge 3500HD SRW 6.7L
Click on my profile for Mods and notes
Jmooney is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.