Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 05-19-2015, 12:06 AM   #1
Junior Member
 
Join Date: Mar 2015
Location: Kodiak
Posts: 10
Found red fine shavings in sink faucet

I have a new 2015 154BH first couple of tanks of water came out fine then all of a sudden the sink faucet would not work. Pulled faucet tip out and found red clear fine plastic shavings clogging faucet. First time owner so anyone else have this issue?
__________________

Chuckwagn is offline   Reply With Quote
Old 05-19-2015, 06:15 AM   #2
Senior Member
 
Join Date: Feb 2012
Location: Myrtle Beach, SC
Posts: 1,261
Kinda typical for a new TT to find sawdust and small construction debris in odd places.. Must have gotten in there when the lines were open during construction. I would have thought in the initial testing they would have caught that.. odd.
__________________

exjay1 is offline   Reply With Quote
Old 05-19-2015, 06:54 AM   #3
Senior Member
 
mike837go's Avatar
 
Join Date: May 2015
Location: Campbell Hall
Posts: 2,837
The pink is from the winterizing antifreeze.

The shavings are from cutting the pipes.
__________________
TT 2015 19RD "TheJayco"
TV 2003 F-350 "Montblanc" - Housebroken chore truck


Sitting in The Cheap Seats.
And proud of it!
mike837go is offline   Reply With Quote
Old 05-19-2015, 07:36 AM   #4
Senior Member
 
Seann45's Avatar
 
Join Date: Jun 2010
Location: Saskatoon Sask Canada
Posts: 9,701
Just clean out all your tap aerators for the next while and things will be fine..
__________________
Seann
2004 Chev Silverado Duramax optioned past the max. 2009 Jayco Eagle 308 RLS 765 watts of solar, 6-6 volt batteries (696 amp hour), 2000 watt (4000 surge) whole house inverter.
175 days boondocking in 2017
215/2016, 211/2015, 196/14, 247/13, 193/12

Seann45 is offline   Reply With Quote
Old 05-19-2015, 08:03 AM   #5
Senior Member
 
Jagiven's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 4,114
Depending on your unit, The water distribution system is plastic, on some units they color code hot and cold (red/blue), it probably some fines from manufacturing. remove the aerators, I would turn on the taps and let if flow for a moment, just incase of other debris. It is fairly common, even in a new or old house.
Jagiven is offline   Reply With Quote
Old 05-19-2015, 09:27 AM   #6
Junior Member
 
Join Date: Mar 2015
Location: Kodiak
Posts: 10
Ok good to know. Thanks everyone
__________________

Chuckwagn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.