Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 07-23-2014, 01:32 PM   #1
Junior Member
 
Join Date: Jan 2014
Location: Port Allen, La.
Posts: 7
2014 Seneca with whistle noise

When driving 55-65 MPH in overdrive, there is a high pitch noise when cruising.... test drove 2 units before I bought this one both had noise ran me away . So got a unit straight from factory.... noise was not there when purchased but it is getting as bad as the other two that I test drove... Help !! Freightliner says they can't find it ! Shop 3 times..
__________________

Danny rab is offline   Reply With Quote
Old 07-23-2014, 03:52 PM   #2
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,038
IIRC there is a service bulletin out that involves the throttle or trans cable. Sounds like it may have been missed before being delivered to JAYCO. Also could be a loose clamp on the tubo hoses.
__________________

__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is online now   Reply With Quote
Old 07-23-2014, 07:36 PM   #3
Junior Member
 
Join Date: Jan 2014
Location: Port Allen, La.
Posts: 7
Thanks Grumpy, I think you hit it right on the head..... Talked to Freightliner and there is a service bulletin for this problem.... going to get it fixed !!!
Danny rab is offline   Reply With Quote
Old 07-23-2014, 10:12 PM   #4
Member
 
Join Date: May 2014
Location: Maple Ridge, BC
Posts: 47
Does it involve a dual clutch or duonic system? I own a commercial truck from the same global family as freightlner and parts and systems are shared cross platform. I've had some issues with my 2012 Fuso transmission. It seems that there may be problems. If it's a 2014 then just enjoy the drive until it breaks then they have cause to fix it under warranty.
__________________
2014 Jayco Jayflight Swift SLX 184bh Baja
2014 Jeep Grand Cherokee Laredo hers(mine)/tow vehicle
2001 Jeep TJ 60th anniversary edition number 769 his(mine)
2012 Mitsubishi Fuso canter fe160
Me, wife, girl, boy
Fawcett is offline   Reply With Quote
Old 07-24-2014, 02:38 PM   #5
Senior Member
 
Mr.Oz's Avatar
 
Join Date: Jul 2014
Location: Hebron
Posts: 214
I have the same noise in mine. It has the shift cable fix done but there still is a noise kinda like a continuous high pitched cricket chirp. Its not real bad. I also had a grunting noise when steering that I traced to the column boot at the firewall. Some lube on the boot and shaft cured that problem. I have 6500miles on mine so far.

Dan
Mr.Oz is offline   Reply With Quote
Old 07-27-2014, 08:59 PM   #6
Junior Member
 
Join Date: Jul 2013
Posts: 20
May want to try checking your max air vents, I closed mine tightly and the noise stopped.
ted h is offline   Reply With Quote
Old 07-29-2014, 12:02 PM   #7
Senior Member
 
Mr.Oz's Avatar
 
Join Date: Jul 2014
Location: Hebron
Posts: 214
It only does it in overdrive. Same speed lower gear no noise. Same rpm slower speed no noise. Almost like a resonance from the trans. Too bad it wouldn't fit on my chassis dyno and duplicate the noise the noise while be able to crawl around under it.
__________________
Dan
2014 Seneca 37 FS
2014 Jeep Wrangler Sahara Unlimited
Mr.Oz is offline   Reply With Quote
Old 07-30-2014, 11:41 PM   #8
Junior Member
 
Join Date: Apr 2014
Location: Fort Madison
Posts: 18
Quote:
Originally Posted by ted h View Post
May want to try checking your max air vents, I closed mine tightly and the noise stopped.
Not quite sure what the max air vents are that you are referring to? How do you close them? I have the same noise in my 2014 37TS. Thanks for info.
iacubbieman52 is offline   Reply With Quote
Old 08-07-2014, 03:19 PM   #9
Senior Member
 
Mr.Oz's Avatar
 
Join Date: Jul 2014
Location: Hebron
Posts: 214
Quote:
Originally Posted by Danny rab View Post
Thanks Grumpy, I think you hit it right on the head..... Talked to Freightliner and there is a service bulletin for this problem.... going to get it fixed !!!
What happened? Do you have a TSB # and/or a copy of the TSB?
__________________
Dan
2014 Seneca 37 FS
2014 Jeep Wrangler Sahara Unlimited
Mr.Oz is offline   Reply With Quote
Old 08-07-2014, 04:28 PM   #10
Junior Member
 
cwasp's Avatar
 
Join Date: May 2014
Location: Shell beach
Posts: 13
I have a copy of the TSB but cannot figure out how to send.
However it can be found on NHTS website. It is NHST ID # 10053493 TSN # 26-50
I had the fix done and I still hear it, however it is quieter.
__________________

cwasp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.