Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 04-30-2015, 05:36 PM   #1
Member
 
firedog's Avatar
 
Join Date: Jun 2014
Location: League City
Posts: 46
2015 Seneca Electronics

Have new Seneca bought in Oct. Two questions, Nav system turns on by itself when parked after driving rig, Why? Also went out the other day to check rig and furnace blower was running, all thermostats were off including LP thank thank goodness, had to flip main switch outside where fan blower is. What would cause this? TIA..
__________________

__________________
2015 Jayco Seneca 37TS
2010 Jeep Wrangler Sahara
2006 Heritage Harley
firedog is offline   Reply With Quote
Old 04-30-2015, 05:53 PM   #2
Senior Member
 
Grumpy's Avatar
 
Join Date: Nov 2011
Location: Where ever the boss says we're going.
Posts: 5,039
Quote:
Originally Posted by firedog View Post
Also went out the other day to check rig and furnace blower was running, all thermostats were off including LP thank thank goodness, had to flip main switch outside where fan blower is. What would cause this? TIA..
If it was hot where you live it could be a faulty thermal switch. It thought the heat exchanger was still hot and told the fan to run.
__________________

__________________
DISNEY LOVERS
PINNACLE 2015 38FLSA. aka: "Roam Sweet Home"
Grumpy is online now   Reply With Quote
Old 04-30-2015, 06:00 PM   #3
Member
 
firedog's Avatar
 
Join Date: Jun 2014
Location: League City
Posts: 46
Thanks Grumpy. It was in the morning, not to hot or don't think hot enough to trigger switch. Kind of freaked me out. If LP was on no telling how long it had been running.
__________________
2015 Jayco Seneca 37TS
2010 Jeep Wrangler Sahara
2006 Heritage Harley
firedog is offline   Reply With Quote
Old 04-30-2015, 07:52 PM   #4
Senior Member
 
anav8or's Avatar
 
Join Date: Nov 2014
Location: Grove City, OH
Posts: 235
We have a 2015 36FK and while we haven't had the same things happen, we've had a few instances where I went to bed with the thermostat in gas mode set to ~64 degrees and woke up to find it had reset itself to 72. I've never seen it run with everything turned off, though.

The radio thing is interesting. I've accidentally left mine on before not remembering that it is powered by the coach 12v system and not the chassis. When I first fire mine up, it defaults to the nav screen. Maybe you had an intermittent 12v connection that resulted in it turning itself on?

The more complex these things become, the more opportunity for gremlins I guess.
__________________
Ty & Deb Montag
Columbus, OH
2015 Jayco Seneca 36FK
2014 Honda CR-V toad

anav8or is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.