Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 09-01-2011, 06:02 AM   #11
Senior Member
 
edatlanta's Avatar
 
Join Date: Dec 2009
Location: Maplesville, AL - Home Base
Posts: 2,523
I must be the exception because I haven't had any issues with my 5'er since I moved in a little over a year ago (has it been that long already?). I did have a couple of the recessed light fixture lens fall out on my second trip, but I think they just weren't installed all the way initially, because I have made several more trips since then and no more problems.
All of my main systems were and are working perfectly.

Keeping my fingers crossed after a year of full timing.
__________________

__________________
Ed
KM4STL

2006 GMC 2500HD CCSB 4x4 Duramax/Allison, Titan 52 gallon fuel tank, Prodigy Controller, B&W Companion Hitch
2010 Jayco Designer 35RLTS, Cummins/Onan RV QG 5500 EVAP, Progressive Industries EMS-PT50C, TST Systems 507 TPMS, RV Flex Armor Roof
edatlanta is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 07:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.