Jayco RV Owners Forum
 


Reply
 
Thread Tools Display Modes
 
Old 08-10-2015, 08:46 AM   #1
Member
 
Join Date: Jun 2015
Location: Oswego
Posts: 48
New 27RLS is HOME!!! Pump question.

Well we replaced our ever dependable 2003 23b with a 2016 27RLS. Man, what a difference in size. Someone is gonna get a great used camper, as it was still in excellent shape. Have to admit that we were a little disappointed at delivery, as it was apparent that our salesman did not go thru the unit prior to our inspection, and was embarrassed at some of the issues we found. Overall though we were pretty happy with the camper. One issue I have noticed is that I can't get all the air out of the water system, and the pumps capacity seems to be lacking. I have the elite package, which has 2 water tanks cross connected. has anyone had this issue, or have any suggestions? Thanks, love this site.
__________________

cosmo is offline   Reply With Quote
Old 08-10-2015, 08:14 PM   #2
Senior Member
 
ctbailey's Avatar
 
Join Date: Nov 2014
Location: New Hampshire
Posts: 558
Sounds like a water pickup line is sucking air. Could be a warranty issue?
__________________

__________________
Craig T. Bailey
Hudson, NH
2015 Jayflight 32BHDS
2007 Chevy 2500HD Crew 4x4 Z71
ctbailey is offline   Reply With Quote
Old 08-12-2015, 11:36 AM   #3
Member
 
Join Date: Jun 2015
Location: Oswego
Posts: 48
While troubleshooting the issue with air in the water system, I crawled underneath the camper to look for a smoking gun. Our camper has the "thermal package" and I couldn't believe how poorly that was installed. Half the zip screws weren't attached to anything, and the seam tape where two pieces were joined had failed. I pushed up where the material was sagging and out came a bunch of water through a weep hole. Found that one of the connections cross connecting the two tanks was loose and leaking, as well as the insulation being soaked. I am really regretting getting this thermal package. Still haven't determined the source of air. I may pull down all of the bottom panel and insulation, and see what other surprises there are.
cosmo is offline   Reply With Quote
Old 09-28-2015, 08:32 AM   #4
Member
 
Join Date: Jun 2015
Location: Oswego
Posts: 48
Well I finally determined the source of air on the pump suction, even though dealer said everything was fine. It ended up being the winterization valve leaking air to the pump. clamped off the tygon, and walla, no more air intrusion, and the pump shuts off immediately after shutting a faucet.
cosmo is offline   Reply With Quote
Old 09-28-2015, 03:51 PM   #5
Senior Member
 
Join Date: Aug 2015
Location: Cumming, Georgia
Posts: 119
Just saw this thread, glad you found the issue. I would have said its probably a loose connection before the pump. Hope you enjoy your unit.
__________________
------------------------------------------
2015 Jayco Eagle Premier 318RETS
2008 Ford F-250 Lariat CC Super Duty 6.4 Turbo Diesel
Cumming, Georgia
Go Dawgs!
Amosmoses33 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Virginia State Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:33 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2002-2016 Social Knowledge, LLC All Rights Reserved.